summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-12-22 19:09:51 +0000
committerAlex Alexander <wired@gentoo.org>2010-12-22 19:09:51 +0000
commit845e6f134b1a4859ee19fd598f906e3782ff8993 (patch)
tree7e4dd5399fee432fceb0ff5c5fa2397c1034aff0 /x11-terms
parentFix last python related changes a suggested by Arfrever (diff)
downloadgentoo-2-845e6f134b1a4859ee19fd598f906e3782ff8993.tar.gz
gentoo-2-845e6f134b1a4859ee19fd598f906e3782ff8993.tar.bz2
gentoo-2-845e6f134b1a4859ee19fd598f906e3782ff8993.zip
added some USE flags, bugs #346613 and #346553, including pixbuf for transparency support.
(Portage version: 2.2.0_alpha9/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog7
-rw-r--r--x11-terms/rxvt-unicode/files/rxvt-unicode-9.10-force-hints.patch17
-rw-r--r--x11-terms/rxvt-unicode/metadata.xml12
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild28
4 files changed, 54 insertions, 10 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 2665fd87c935..a40878acacfa 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.173 2010/12/13 20:15:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.174 2010/12/22 19:09:51 wired Exp $
+
+ 22 Dec 2010; Alex Alexander <wired@gentoo.org> rxvt-unicode-9.10.ebuild,
+ +files/rxvt-unicode-9.10-force-hints.patch, metadata.xml:
+ added some USE flags, bugs #346613 and #346553, including pixbuf for
+ transparency support.
*rxvt-unicode-9.10 (13 Dec 2010)
diff --git a/x11-terms/rxvt-unicode/files/rxvt-unicode-9.10-force-hints.patch b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.10-force-hints.patch
new file mode 100644
index 000000000000..0148ba95445e
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.10-force-hints.patch
@@ -0,0 +1,17 @@
+patch that forces hints on rxvt-unicode's geometry.
+
+for more info, read this Gentoo bug:
+http://bugs.gentoo.org/show_bug.cgi?id=346553
+--- src/main.C
++++ src/main.C
+@@ -644,6 +644,8 @@
+
+ ncol = width / fwidth;
+ nrow = height / fheight;
++ width = ncol * fwidth;
++ height = nrow * fheight;
+ }
+
+ /*----------------------------------------------------------------------*/
+
+
diff --git a/x11-terms/rxvt-unicode/metadata.xml b/x11-terms/rxvt-unicode/metadata.xml
index e3e355410072..f300e9174a8c 100644
--- a/x11-terms/rxvt-unicode/metadata.xml
+++ b/x11-terms/rxvt-unicode/metadata.xml
@@ -12,10 +12,18 @@
</maintainer>
<use>
<flag name='256-color'>Enable 256 color support</flag>
- <flag name='afterimage'>Enable support for
+ <flag name='afterimage'>Enable transparency support using
<pkg>media-libs/libafterimage</pkg></flag>
- <flag name='iso14755'>Enable ISO-14755 support</flag>
<flag name='blink'>Enable blinking text</flag>
+ <flag name='fading-colors'>Enable colors fading when off focus</flag>
+ <flag name='font-styles'>Enable support for bold and italic fonts</flag>
+ <flag name='force-hints'>Force WM hints on rxvt-unicode's geometry. Read
+ http://bugs.gentoo.org/show_bug.cgi?id=346553</flag>
+ <flag name='iso14755'>Enable ISO-14755 support</flag>
+ <flag name='pixbuf'>Enable transparency support using
+ gtk's pixbuf</flag>
+ <flag name='unicode3'>Use 21 instead of 16 bits to represent
+ unicode characters</flag>
<flag name='wcwidth'>Enable wide char width support</flag>
<flag name='xterm-color'>Enable xterm 256 color support</flag>
</use>
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild
index 919bdbf9415f..a273227d9cba 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild,v 1.1 2010/12/13 20:15:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild,v 1.2 2010/12/22 19:09:51 wired Exp $
EAPI="3"
@@ -13,20 +13,28 @@ SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="256-color afterimage iso14755 perl blink truetype +vanilla wcwidth"
+IUSE="256-color afterimage blink fading-colors +font-styles force-hints iso14755 perl pixbuf truetype unicode3 +vanilla wcwidth"
# see bug #115992 for modular x deps
RDEPEND="x11-libs/libX11
x11-libs/libXft
- afterimage? ( || ( media-libs/libafterimage x11-wm/afterstep ) )
x11-libs/libXrender
+ >=sys-libs/ncurses-5.7-r6
+ afterimage? ( || ( media-libs/libafterimage x11-wm/afterstep ) )
perl? ( dev-lang/perl )
- >=sys-libs/ncurses-5.7-r6"
+ pixbuf? ( || ( >=x11-libs/gdk-pixbuf-2.21 <=x11-libs/gtk+-2.21 ) )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
x11-proto/xproto"
src_prepare() {
+ if ! use afterimage && ! use pixbuf; then
+ einfo
+ einfo "If you want transparency support, please enable either the *pixbuf*"
+ einfo "or the *afterimage* USE flag. Enabling both will default to pixbuf."
+ einfo
+ fi
+
if use wcwidth; then
ewarn "You enabled wcwidth."
ewarn "Please note that this is not supported by upstream."
@@ -47,6 +55,9 @@ src_prepare() {
# bug #263638
epatch "${FILESDIR}"/${PN}-9.06-popups-hangs.patch
+ # bug #346553
+ use force-hints && epatch "${FILESDIR}"/${PN}-9.10-force-hints.patch
+
# bug #237271
if ! use vanilla; then
ewarn "You are going to include third-party bug fixes/features."
@@ -65,12 +76,15 @@ src_configure() {
use iso14755 || myconf='--disable-iso14755'
econf --enable-everything \
- --disable-pixbuf \
- $(use_enable truetype xft) \
$(use_enable 256-color) \
$(use_enable afterimage) \
- $(use_enable perl) \
$(use_enable blink text-blink) \
+ $(use_enable fading-colors fading) \
+ $(use_enable font-styles) \
+ $(use_enable perl) \
+ $(use_enable pixbuf) \
+ $(use_enable truetype xft) \
+ $(use_enable unicode3) \
${myconf}
}