summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-12-13 20:15:59 +0000
committerJeroen Roovers <jer@gentoo.org>2010-12-13 20:15:59 +0000
commit6e1eff5e60a62aef35adbeed5b11100a58f4b2c1 (patch)
treee3514da872f1c348ff06077ea5314435dbac7ad2 /x11-terms
parentDelete older ebuilds. (diff)
downloadgentoo-2-6e1eff5e60a62aef35adbeed5b11100a58f4b2c1.tar.gz
gentoo-2-6e1eff5e60a62aef35adbeed5b11100a58f4b2c1.tar.bz2
gentoo-2-6e1eff5e60a62aef35adbeed5b11100a58f4b2c1.zip
Version bump by Justin Lecher (bug #348637).
(Portage version: 2.2.0_alpha8/cvs/Linux i686)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog7
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild91
2 files changed, 97 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 3477462943ab..2665fd87c935 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.172 2010/11/16 21:38:47 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.173 2010/12/13 20:15:59 jer Exp $
+
+*rxvt-unicode-9.10 (13 Dec 2010)
+
+ 13 Dec 2010; Jeroen Roovers <jer@gentoo.org> +rxvt-unicode-9.10.ebuild:
+ Version bump by Justin Lecher (bug #348637).
*rxvt-unicode-9.09 (15 Nov 2010)
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild
new file mode 100644
index 000000000000..919bdbf9415f
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.10.ebuild,v 1.1 2010/12/13 20:15:59 jer Exp $
+
+EAPI="3"
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="256-color afterimage iso14755 perl blink truetype +vanilla wcwidth"
+
+# see bug #115992 for modular x deps
+RDEPEND="x11-libs/libX11
+ x11-libs/libXft
+ afterimage? ( || ( media-libs/libafterimage x11-wm/afterstep ) )
+ x11-libs/libXrender
+ perl? ( dev-lang/perl )
+ >=sys-libs/ncurses-5.7-r6"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ if use wcwidth; then
+ ewarn "You enabled wcwidth."
+ ewarn "Please note that this is not supported by upstream."
+ ewarn "You are at your own if you run into problems."
+ fi
+
+ local tdir=/usr/share/terminfo
+
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in ||
+ die "sed failed"
+
+ use wcwidth && epatch doc/wcwidth.patch
+
+ # bug #240165
+ epatch "${FILESDIR}"/${PN}-9.06-no-urgency-if-focused.diff
+
+ # bug #263638
+ epatch "${FILESDIR}"/${PN}-9.06-popups-hangs.patch
+
+ # bug #237271
+ if ! use vanilla; then
+ ewarn "You are going to include third-party bug fixes/features."
+ ewarn "They came without any warranty and are not supported by the"
+ ewarn "Gentoo community."
+ epatch "${FILESDIR}"/${PN}-9.05_no-MOTIF-WM-INFO.patch
+ epatch "${FILESDIR}"/${PN}-9.06-font-width.patch
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+
+ econf --enable-everything \
+ --disable-pixbuf \
+ $(use_enable truetype xft) \
+ $(use_enable 256-color) \
+ $(use_enable afterimage) \
+ $(use_enable perl) \
+ $(use_enable blink text-blink) \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}