summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-11-27 06:14:45 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-11-27 06:14:45 +0000
commit6b72bc0c3740ae9e88b8e4dcb606c3df3162a6b5 (patch)
treee498e2962bb8045930fdb3f58e47239cba1cc1b9 /x11-terms
parentadd new Lincen Lab FLOSS exception to GPL-2 license for Second Life (diff)
downloadgentoo-2-6b72bc0c3740ae9e88b8e4dcb606c3df3162a6b5.tar.gz
gentoo-2-6b72bc0c3740ae9e88b8e4dcb606c3df3162a6b5.tar.bz2
gentoo-2-6b72bc0c3740ae9e88b8e4dcb606c3df3162a6b5.zip
Fix ldflags and ldlibs ordering to respect users flags. Install target had all, which caused everything to get rebuilt at install phase which is not desired behavior. Thanks to leio wrt #249050.
(Portage version: 2.2_rc15/cvs/Linux 2.6.27-gentoo-r3 i686)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/evilvte/ChangeLog11
-rw-r--r--x11-terms/evilvte/evilvte-0.4.4_pre6-r1.ebuild50
-rw-r--r--x11-terms/evilvte/evilvte-0.4.4_pre6.ebuild4
-rw-r--r--x11-terms/evilvte/files/evilvte-0.4.4_pre6-fix_ldflags_and_ldlibs_for_asneeded.patch33
4 files changed, 95 insertions, 3 deletions
diff --git a/x11-terms/evilvte/ChangeLog b/x11-terms/evilvte/ChangeLog
index eb3f70df2183..8a6f1b81bbf5 100644
--- a/x11-terms/evilvte/ChangeLog
+++ b/x11-terms/evilvte/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-terms/evilvte
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/evilvte/ChangeLog,v 1.4 2008/11/26 13:42:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/evilvte/ChangeLog,v 1.5 2008/11/27 06:14:45 ssuominen Exp $
+
+*evilvte-0.4.4_pre6-r1 (27 Nov 2008)
+
+ 27 Nov 2008; <ssuominen@gentoo.org>
+ +files/evilvte-0.4.4_pre6-fix_ldflags_and_ldlibs_for_asneeded.patch,
+ evilvte-0.4.4_pre6.ebuild, +evilvte-0.4.4_pre6-r1.ebuild:
+ Fix ldflags and ldlibs ordering to respect users flags. Install target had
+ all, which caused everything to get rebuilt at install phase which is not
+ desired behavior. Thanks to leio wrt #249050.
*evilvte-0.4.4_pre6 (26 Nov 2008)
diff --git a/x11-terms/evilvte/evilvte-0.4.4_pre6-r1.ebuild b/x11-terms/evilvte/evilvte-0.4.4_pre6-r1.ebuild
new file mode 100644
index 000000000000..fa351c768b69
--- /dev/null
+++ b/x11-terms/evilvte/evilvte-0.4.4_pre6-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/evilvte/evilvte-0.4.4_pre6-r1.ebuild,v 1.1 2008/11/27 06:14:45 ssuominen Exp $
+
+MY_P=${P/_/\~}
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="VTE based, super lightweight terminal emulator"
+HOMEPAGE="http://www.calno.com/evilvte"
+SRC_URI="http://www.calno.com/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/vte
+ >=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-fix_ldflags_and_ldlibs_for_asneeded.patch
+
+ if [[ -f /etc/${PN}/config.h ]]; then
+ cp /etc/${PN}/config.h src/ || die "copying config.h failed."
+ fi
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die "./configure failed."
+ emake LDFLAGS="${LDFLAGS}" OPTFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc Changelog
+ insinto /etc/${PN}
+ doins src/config.h || die "doins failed."
+}
+
+pkg_postinst() {
+ elog "Edit /etc/${PN}/config.h and re-emerge for custom configuration."
+}
diff --git a/x11-terms/evilvte/evilvte-0.4.4_pre6.ebuild b/x11-terms/evilvte/evilvte-0.4.4_pre6.ebuild
index dbdcdd28d969..6e8930b42b0f 100644
--- a/x11-terms/evilvte/evilvte-0.4.4_pre6.ebuild
+++ b/x11-terms/evilvte/evilvte-0.4.4_pre6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/evilvte/evilvte-0.4.4_pre6.ebuild,v 1.1 2008/11/26 13:42:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/evilvte/evilvte-0.4.4_pre6.ebuild,v 1.2 2008/11/27 06:14:45 ssuominen Exp $
MY_P=${P/_/\~}
@@ -32,7 +32,7 @@ src_unpack() {
src_compile() {
./configure --prefix=/usr || die "./configure failed."
- emake OPTFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed."
+ emake LDFLAGS="${LDFLAGS}" OPTFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed."
}
src_install() {
diff --git a/x11-terms/evilvte/files/evilvte-0.4.4_pre6-fix_ldflags_and_ldlibs_for_asneeded.patch b/x11-terms/evilvte/files/evilvte-0.4.4_pre6-fix_ldflags_and_ldlibs_for_asneeded.patch
new file mode 100644
index 000000000000..9c3f97e6ad1a
--- /dev/null
+++ b/x11-terms/evilvte/files/evilvte-0.4.4_pre6-fix_ldflags_and_ldlibs_for_asneeded.patch
@@ -0,0 +1,33 @@
+diff -ur evilvte-0.4.4~pre6.orig/configure evilvte-0.4.4~pre6/configure
+--- evilvte-0.4.4~pre6.orig/configure 2008-11-15 12:01:06.000000000 +0200
++++ evilvte-0.4.4~pre6/configure 2008-11-27 08:03:39.000000000 +0200
+@@ -78,7 +78,7 @@
+ echo "deskdir=\$(DESTDIR)$deskdir" >> src/config.o
+ echo "ICON_DIR=$ICON_DIR" >> src/config.o
+ echo "ICON_DIR_INSTALL=\$(DESTDIR)$ICON_DIR" >> src/config.o
+-echo "LDFLAGS=-L/usr/local/lib -lvte -lgtk-x11-2.0" >> src/config.o
++echo "LDLIBS=-L/usr/local/lib -lvte -lgtk-x11-2.0" >> src/config.o
+ echo "PROG=$PROG" >> src/config.o
+ echo "EVILVTE_VERSION=$EVILVTE_VERSION" >> src/config.o
+ echo "SUSE_DETECTED=$SUSE_DETECTED" >> src/config.o
+diff -ur evilvte-0.4.4~pre6.orig/Makefile evilvte-0.4.4~pre6/Makefile
+--- evilvte-0.4.4~pre6.orig/Makefile 2008-11-15 12:01:06.000000000 +0200
++++ evilvte-0.4.4~pre6/Makefile 2008-11-27 08:10:46.000000000 +0200
+@@ -16,7 +16,7 @@
+ sh src/evilvte.sh
+
+ evilvte: src/evilvte.h $(OBJ)
+- $(CC) -o $(PROG) $(OBJ) $(LDFLAGS)
++ $(CC) $(LDFLAGS) $(OBJ) $(LDLIBS) -o $(PROG)
+
+ strip: all
+ strip --remove-section=.comment --remove-section=.note $(PROG)
+@@ -32,7 +32,7 @@
+ misc/evilvte.1:
+ sh src/manpage.sh
+
+-install: all
++install:
+ install -d $(bindir)
+ install -m 755 $(PROG) src/showvte $(bindir)
+ install -d $(ICON_DIR_INSTALL)