summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené Nussbaumer <killerfox@gentoo.org>2007-12-16 13:45:05 +0000
committerRené Nussbaumer <killerfox@gentoo.org>2007-12-16 13:45:05 +0000
commitc9af74f3b475ae256dcf503e54c5ac4f4259932b (patch)
treea3dab818f9bb13cb5d296cf1c72ad777be2e38e0 /x11-terms/rxvt-unicode
parentversion bump; vdr-vcd-0.7 fixed broken DL URI (diff)
downloadgentoo-2-c9af74f3b475ae256dcf503e54c5ac4f4259932b.tar.gz
gentoo-2-c9af74f3b475ae256dcf503e54c5ac4f4259932b.tar.bz2
gentoo-2-c9af74f3b475ae256dcf503e54c5ac4f4259932b.zip
Version bump by upstream
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-terms/rxvt-unicode')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog8
-rw-r--r--x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.83
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-8.8.ebuild66
3 files changed, 76 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 02e9042e7a72..06ad7b4955c7 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.99 2007/11/13 20:01:59 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.100 2007/12/16 13:45:04 killerfox Exp $
+
+*rxvt-unicode-8.8 (16 Dec 2007)
+
+ 16 Dec 2007; René Nussbaumer <killerfox@gentoo.org>
+ +rxvt-unicode-8.8.ebuild:
+ Version bump by upstream
13 Nov 2007; Jeroen Roovers <jer@gentoo.org> rxvt-unicode-8.3.ebuild:
Stable for HPPA (bug #198780).
diff --git a/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.8 b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.8
new file mode 100644
index 000000000000..58739fef3039
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/digest-rxvt-unicode-8.8
@@ -0,0 +1,3 @@
+MD5 a009fa049c4d3dddacd37f8328b6be20 rxvt-unicode-8.8.tar.bz2 857986
+RMD160 5662bd1daaddcd997703329220db913a8ce1508d rxvt-unicode-8.8.tar.bz2 857986
+SHA256 c2f63a77a232c99f37620b995b3a6b25331027e4e2af3fec7aeb557e37f40cf0 rxvt-unicode-8.8.tar.bz2 857986
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-8.8.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-8.8.ebuild
new file mode 100644
index 000000000000..a4d86bafb30a
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-8.8.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-8.8.ebuild,v 1.1 2007/12/16 13:45:04 killerfox Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="rxvt clone with XFT and Unicode support"
+HOMEPAGE="http://software.schmorp.de/"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype perl iso14755"
+
+# see bug #115992 for modular x deps
+RDEPEND="x11-libs/libX11
+ x11-libs/libXft
+ media-libs/libafterimage
+ x11-libs/libXrender
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ local tdir=/usr/share/terminfo
+ sed -i -e \
+ "s~@TIC@ \(\$(srcdir)/etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
+ doc/Makefile.in
+}
+
+src_compile() {
+ myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+
+ econf \
+ --enable-everything \
+ $(use_enable truetype xft) \
+ $(use_enable perl) \
+ --disable-text-blink \
+ ${myconf} \
+ || die
+
+ emake || die
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}
+
+pkg_postinst() {
+ einfo "urxvt now always uses TERM=rxvt-unicode so that the"
+ einfo "upstream-supplied terminfo files can be used."
+}