summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-10-25 18:33:52 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-10-25 18:33:52 +0000
commitf15833977aa35c19800d136f26b8820d383cf839 (patch)
tree50e447484259bc76ced81c798a55810b8043cc37 /x11-plugins
parentImplement a better way to find the latest autotools to use. (diff)
downloadgentoo-2-f15833977aa35c19800d136f26b8820d383cf839.tar.gz
gentoo-2-f15833977aa35c19800d136f26b8820d383cf839.tar.bz2
gentoo-2-f15833977aa35c19800d136f26b8820d383cf839.zip
* bug #148163
(Portage version: 2.1.2_pre3-r8)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/licq-osd/ChangeLog10
-rw-r--r--x11-plugins/licq-osd/files/digest-licq-osd-1.2.7.5-r12
-rw-r--r--x11-plugins/licq-osd/files/digest-licq-osd-1.3.2.23
-rw-r--r--x11-plugins/licq-osd/licq-osd-1.3.2.2.ebuild39
4 files changed, 52 insertions, 2 deletions
diff --git a/x11-plugins/licq-osd/ChangeLog b/x11-plugins/licq-osd/ChangeLog
index 647b5a7313e6..4193f811b9f2 100644
--- a/x11-plugins/licq-osd/ChangeLog
+++ b/x11-plugins/licq-osd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/licq-osd
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/licq-osd/ChangeLog,v 1.4 2005/10/11 09:51:45 greg_g Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/licq-osd/ChangeLog,v 1.5 2006/10/25 18:33:52 voxus Exp $
+
+*licq-osd-1.3.2.2 (25 Oct 2006)
+
+ 25 Oct 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +licq-osd-1.3.2.2.ebuild:
+ Version bump, closing bug #148163.
*licq-osd-1.2.7.5-r1 (15 Mar 2005)
diff --git a/x11-plugins/licq-osd/files/digest-licq-osd-1.2.7.5-r1 b/x11-plugins/licq-osd/files/digest-licq-osd-1.2.7.5-r1
index f3d9162e67ee..d9e564ef10bb 100644
--- a/x11-plugins/licq-osd/files/digest-licq-osd-1.2.7.5-r1
+++ b/x11-plugins/licq-osd/files/digest-licq-osd-1.2.7.5-r1
@@ -1 +1,3 @@
MD5 d78b0f5ca94176ee768a78a95b06e0a2 osd-1.2.7.5.tgz 311030
+RMD160 f57ab09a674752f9792faa52d511a29ddb644479 osd-1.2.7.5.tgz 311030
+SHA256 df7703f0b2a1eda2143a6d56c6feccbed4471f417ed67b4fc2da6dc828130fc6 osd-1.2.7.5.tgz 311030
diff --git a/x11-plugins/licq-osd/files/digest-licq-osd-1.3.2.2 b/x11-plugins/licq-osd/files/digest-licq-osd-1.3.2.2
new file mode 100644
index 000000000000..5c3fc4cd63ed
--- /dev/null
+++ b/x11-plugins/licq-osd/files/digest-licq-osd-1.3.2.2
@@ -0,0 +1,3 @@
+MD5 3476f5bd79719f89786df69c2f8bc0cd osd_1.3.2.2.tgz 308140
+RMD160 e1ee924d9b8f621b9451a505d11018543a5b0528 osd_1.3.2.2.tgz 308140
+SHA256 45aa2881189846b89acb021e78079d77cb529e420ce84bc5965e87d8db58733c osd_1.3.2.2.tgz 308140
diff --git a/x11-plugins/licq-osd/licq-osd-1.3.2.2.ebuild b/x11-plugins/licq-osd/licq-osd-1.3.2.2.ebuild
new file mode 100644
index 000000000000..98624228f45a
--- /dev/null
+++ b/x11-plugins/licq-osd/licq-osd-1.3.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/licq-osd/licq-osd-1.3.2.2.ebuild,v 1.1 2006/10/25 18:33:52 voxus Exp $
+
+inherit multilib
+
+DESCRIPTION="On Screen Display for licq"
+HOMEPAGE="http://sourceforge.net/projects/licq-osd"
+SRC_URI="mirror://sourceforge/${PN}/osd_${PV}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="nls"
+DEPEND=">=net-im/licq-1.3.0_pre
+ >=x11-libs/xosd-2.2.2
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/osd-${PV}
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ myconf="${myconf} --with-licq-includes=/usr/include/licq"
+ myconf="${myconf} --with-cvs"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc README licq_osd.conf TODO AUTHORS
+
+ cd ${D}/usr/$(get_libdir)
+ mkdir licq
+ mv licq_osd.{so,la} licq/
+}