summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-04-24 21:25:24 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-04-24 21:25:24 +0000
commitba6ec71c514f132e7f12d83144722c6268b45b1c (patch)
tree5c8850708f92c7352c2ece4df2cec969f10f0feb /x11-plugins
parentRemove ruby18 support. EAPI bump. (diff)
downloadgentoo-2-ba6ec71c514f132e7f12d83144722c6268b45b1c.tar.gz
gentoo-2-ba6ec71c514f132e7f12d83144722c6268b45b1c.tar.bz2
gentoo-2-ba6ec71c514f132e7f12d83144722c6268b45b1c.zip
Fix compilation with current openssl, version bump, fixes bug #507984
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmaiload/ChangeLog8
-rw-r--r--x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild3
-rw-r--r--x11-plugins/wmmaiload/wmmaiload-2.3.0.ebuild46
3 files changed, 55 insertions, 2 deletions
diff --git a/x11-plugins/wmmaiload/ChangeLog b/x11-plugins/wmmaiload/ChangeLog
index dc9a480a1c5d..6daa7a866d13 100644
--- a/x11-plugins/wmmaiload/ChangeLog
+++ b/x11-plugins/wmmaiload/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmmaiload
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/ChangeLog,v 1.36 2014/04/07 19:36:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/ChangeLog,v 1.37 2014/04/24 21:25:24 voyageur Exp $
+
+*wmmaiload-2.3.0 (24 Apr 2014)
+
+ 24 Apr 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ wmmaiload-2.2.1-r1.ebuild, +wmmaiload-2.3.0.ebuild:
+ Fix compilation with current openssl, version bump, fixes bug #507984
07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> wmmaiload-2.2.1-r1.ebuild:
Use EAPI5 instead of EAPI1.
diff --git a/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild b/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild
index 822213bce9ff..a81860661d54 100644
--- a/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild
+++ b/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild,v 1.10 2014/04/07 19:36:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild,v 1.11 2014/04/24 21:25:24 voyageur Exp $
EAPI=5
inherit eutils toolchain-funcs
@@ -23,6 +23,7 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-gtk.patch \
"${FILESDIR}"/${P}-checkthread.patch
+ sed -i -e "s/-lssl/\0 -lcrypto/" wmmaiload/Init.make || die "sed failed"
}
src_configure() {
diff --git a/x11-plugins/wmmaiload/wmmaiload-2.3.0.ebuild b/x11-plugins/wmmaiload/wmmaiload-2.3.0.ebuild
new file mode 100644
index 000000000000..1d639740a54c
--- /dev/null
+++ b/x11-plugins/wmmaiload/wmmaiload-2.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/wmmaiload-2.3.0.ebuild,v 1.1 2014/04/24 21:25:24 voyageur Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="dockapp that monitors one or more mailboxes."
+HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
+SRC_URI="http://tnemeth.free.fr/projets/programmes/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.2.1-checkthread.patch
+ sed -i -e "s/-lssl/\0 -lcrypto/" wmmaiload/Init.make || die "sed failed"
+}
+
+src_configure() {
+ # The ./configure script is not autoconf based, therefore don't use econf:
+ ./configure -p /usr || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ DEBUG_LDFLAGS="" \
+ LDFLAGS="${LDFLAGS}" \
+ DEBUG_CFLAGS=""
+}
+
+src_install() {
+ dobin ${PN}/${PN} ${PN}-config/${PN}-config
+ doman doc/*.1
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO doc/sample.${PN}rc
+}