summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:59:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:59:53 +0000
commitba6aaea815c07ee7855759ac17d155fe86661e6b (patch)
tree3b8efa22ba7fd0fc074628256460b139756d2adc /x11-plugins
parentUse EAPI5 instead of EAPI1. Missing inherit eutils for epatch. (diff)
downloadgentoo-2-ba6aaea815c07ee7855759ac17d155fe86661e6b.tar.gz
gentoo-2-ba6aaea815c07ee7855759ac17d155fe86661e6b.tar.bz2
gentoo-2-ba6aaea815c07ee7855759ac17d155fe86661e6b.zip
Use EAPI5 instead of EAPI1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmclockmon/ChangeLog9
-rw-r--r--x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild13
2 files changed, 10 insertions, 12 deletions
diff --git a/x11-plugins/wmclockmon/ChangeLog b/x11-plugins/wmclockmon/ChangeLog
index 3d2bbb31ba23..37507718f511 100644
--- a/x11-plugins/wmclockmon/ChangeLog
+++ b/x11-plugins/wmclockmon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmclockmon
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmclockmon/ChangeLog,v 1.34 2012/05/05 05:12:02 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmclockmon/ChangeLog,v 1.35 2014/04/07 19:59:53 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> wmclockmon-0.8.1.ebuild:
+ Use EAPI5 instead of EAPI1.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> wmclockmon-0.8.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -135,5 +138,3 @@
29 Oct 2002; Brad Cowan <bcowan@gentoo.org> wmclockmon-0.1.3.ebuild,
ChangeLog, files/digest-wmclockmon-0.1.3 :
Initial import thanks to Autobot.
-
-
diff --git a/x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild b/x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild
index 24c025bc6d22..2b23341c8e6f 100644
--- a/x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild
+++ b/x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild,v 1.7 2012/05/05 05:12:02 jdhore Exp $
-
-EAPI="1"
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmclockmon/wmclockmon-0.8.1.ebuild,v 1.8 2014/04/07 19:59:53 ssuominen Exp $
+EAPI=5
inherit eutils
DESCRIPTION="a nice digital clock with 7 different styles either in LCD or LED style."
@@ -25,14 +24,12 @@ DEPEND="${RDEPEND}
x11-proto/xextproto
x11-libs/libXt"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gtk.patch
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install
dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/sample*
newdoc debian/changelog ChangeLog.debian
}