summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2012-03-20 20:28:01 +0000
committerIan Whyman <thev00d00@gentoo.org>2012-03-20 20:28:01 +0000
commita856c360f1f32d2044f04df0f66491f598b168fd (patch)
treeccafe757ad4f5ea16e5ac6f1f7a8e88ea1428ab8 /x11-plugins
parentVersion bump. Don't require user to choose from ncurses/slang (bug #353679 by... (diff)
downloadgentoo-2-a856c360f1f32d2044f04df0f66491f598b168fd.tar.gz
gentoo-2-a856c360f1f32d2044f04df0f66491f598b168fd.tar.bz2
gentoo-2-a856c360f1f32d2044f04df0f66491f598b168fd.zip
Bump to 1.13.0
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-sipe/ChangeLog7
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.13.0.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-sipe/ChangeLog b/x11-plugins/pidgin-sipe/ChangeLog
index 541648f9ffa6..0ed378ba968d 100644
--- a/x11-plugins/pidgin-sipe/ChangeLog
+++ b/x11-plugins/pidgin-sipe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/pidgin-sipe
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.10 2012/01/10 20:03:35 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.11 2012/03/20 20:28:01 thev00d00 Exp $
+
+*pidgin-sipe-1.13.0 (20 Mar 2012)
+
+ 20 Mar 2012; Ian Whyman <thev00d00@gentoo.org> +pidgin-sipe-1.13.0.ebuild:
+ Bump to 1.13.0
10 Jan 2012; Ian Whyman <thev00d00@gentoo.org> -pidgin-sipe-1.3.3.ebuild,
-pidgin-sipe-1.7.0.ebuild, -pidgin-sipe-1.7.1.ebuild,
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.13.0.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.13.0.ebuild
new file mode 100644
index 000000000000..bbfbf0a24fa3
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/pidgin-sipe-1.13.0.ebuild,v 1.1 2012/03/20 20:28:01 thev00d00 Exp $
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kerberos voice"
+
+DEPEND="net-im/pidgin[gnutls]
+ dev-util/intltool
+ >=dev-libs/gmime-2.4.16
+ dev-libs/libxml2
+ kerberos? ( app-crypt/mit-krb5 )
+ voice? (
+ >=dev-libs/glib-2.28.0
+ >=net-libs/libnice-0.1.0
+ media-libs/gstreamer )
+ !voice? ( >=dev-libs/glib-2.12.0 )"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-purple \
+ --disable-quality-check \
+ --disable-telepathy \
+ $(use_with voice vv) \
+ $(use_enable debug) \
+ $(use_with kerberos krb5)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS TODO README
+}