summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-03-25 13:55:42 +0000
committerJeroen Roovers <jer@gentoo.org>2014-03-25 13:55:42 +0000
commit6a0edd60e439f5df7831548a050bdd5030ec0273 (patch)
tree7eff37df178eb3ba4f2c7136f51bb640e242fd2c /x11-plugins
parentVersion bump. (diff)
downloadgentoo-2-6a0edd60e439f5df7831548a050bdd5030ec0273.tar.gz
gentoo-2-6a0edd60e439f5df7831548a050bdd5030ec0273.tar.bz2
gentoo-2-6a0edd60e439f5df7831548a050bdd5030ec0273.zip
Fix some compiler warnings.
(Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/asapm/ChangeLog6
-rw-r--r--x11-plugins/asapm/asapm-3.1-r1.ebuild4
-rw-r--r--x11-plugins/asapm/files/asapm-3.1-include.patch10
3 files changed, 17 insertions, 3 deletions
diff --git a/x11-plugins/asapm/ChangeLog b/x11-plugins/asapm/ChangeLog
index 05bf9fad7063..1925e8b318ed 100644
--- a/x11-plugins/asapm/ChangeLog
+++ b/x11-plugins/asapm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/asapm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asapm/ChangeLog,v 1.20 2014/03/23 17:32:23 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asapm/ChangeLog,v 1.21 2014/03/25 13:55:42 jer Exp $
+
+ 25 Mar 2014; Jeroen Roovers <jer@gentoo.org> asapm-3.1-r1.ebuild,
+ +files/asapm-3.1-include.patch:
+ Fix some compiler warnings.
*asapm-3.1-r1 (23 Mar 2014)
diff --git a/x11-plugins/asapm/asapm-3.1-r1.ebuild b/x11-plugins/asapm/asapm-3.1-r1.ebuild
index 68c90ff8c29a..c6bc1115bdb3 100644
--- a/x11-plugins/asapm/asapm-3.1-r1.ebuild
+++ b/x11-plugins/asapm/asapm-3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asapm/asapm-3.1-r1.ebuild,v 1.1 2014/03/23 17:32:23 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asapm/asapm-3.1-r1.ebuild,v 1.2 2014/03/25 13:55:42 jer Exp $
EAPI=5
@@ -26,7 +26,7 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}"/${P}-{ldflags,include}.patch
}
src_install() {
diff --git a/x11-plugins/asapm/files/asapm-3.1-include.patch b/x11-plugins/asapm/files/asapm-3.1-include.patch
new file mode 100644
index 000000000000..529d994ef122
--- /dev/null
+++ b/x11-plugins/asapm/files/asapm-3.1-include.patch
@@ -0,0 +1,10 @@
+--- a/apm_read.c
++++ b/apm_read.c
+@@ -13,6 +13,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h> /* exit(), free() */
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <unistd.h>