summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-02-24 18:06:45 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-02-24 18:06:45 +0000
commit43ead55cf3c2e1b0692988cde65a30d8831514d6 (patch)
tree555334a5336c1581df9d2653dbc61cfa612114c5 /x11-plugins
parentVersion bump; Drop old. (diff)
downloadgentoo-2-43ead55cf3c2e1b0692988cde65a30d8831514d6.tar.gz
gentoo-2-43ead55cf3c2e1b0692988cde65a30d8831514d6.tar.bz2
gentoo-2-43ead55cf3c2e1b0692988cde65a30d8831514d6.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmudmount/ChangeLog7
-rw-r--r--x11-plugins/wmudmount/wmudmount-2.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/x11-plugins/wmudmount/ChangeLog b/x11-plugins/wmudmount/ChangeLog
index 51f7ffab3d41..e22f09e85cab 100644
--- a/x11-plugins/wmudmount/ChangeLog
+++ b/x11-plugins/wmudmount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmudmount
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.15 2014/02/09 23:51:51 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.16 2014/02/24 18:06:45 voyageur Exp $
+
+*wmudmount-2.1 (24 Feb 2014)
+
+ 24 Feb 2014; Bernard Cafarelli <voyageur@gentoo.org> +wmudmount-2.1.ebuild:
+ Version bump
*wmudmount-2.0 (09 Feb 2014)
diff --git a/x11-plugins/wmudmount/wmudmount-2.1.ebuild b/x11-plugins/wmudmount/wmudmount-2.1.ebuild
new file mode 100644
index 000000000000..52f8420c1a5c
--- /dev/null
+++ b/x11-plugins/wmudmount/wmudmount-2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/wmudmount-2.1.ebuild,v 1.1 2014/02/24 18:06:45 voyageur Exp $
+
+EAPI=5
+inherit eutils gnome2-utils
+
+DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
+HOMEPAGE="http://sourceforge.net/projects/wmudmount/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring libnotify"
+
+RDEPEND="sys-fs/udisks:2
+ >=x11-libs/gtk+-3.8.0:3
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
+
+DOCS="ChangeLog"
+
+src_configure() {
+ econf \
+ $(use_with libnotify) \
+ $(use_with gnome-keyring)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }