summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-12-01 14:46:11 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-12-01 14:46:11 +0000
commit31b9987866bb260ba14c677e73bdaf8208102c42 (patch)
tree72b55f97d0f4802726ff910cb9598c422e2a3422 /x11-plugins
parentRemove python_need_rebuild, it is now in the eclass. (diff)
downloadgentoo-2-31b9987866bb260ba14c677e73bdaf8208102c42.tar.gz
gentoo-2-31b9987866bb260ba14c677e73bdaf8208102c42.tar.bz2
gentoo-2-31b9987866bb260ba14c677e73bdaf8208102c42.zip
Version bump, adds custom emoticon sending support and independent personal status messages
(Portage version: 2.2_rc16/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-msn-pecan/ChangeLog9
-rw-r--r--x11-plugins/pidgin-msn-pecan/pidgin-msn-pecan-0.0.17.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-msn-pecan/ChangeLog b/x11-plugins/pidgin-msn-pecan/ChangeLog
index e65c1b8d46bf..81b2aa12d977 100644
--- a/x11-plugins/pidgin-msn-pecan/ChangeLog
+++ b/x11-plugins/pidgin-msn-pecan/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/pidgin-msn-pecan
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-msn-pecan/ChangeLog,v 1.4 2008/09/14 22:46:14 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-msn-pecan/ChangeLog,v 1.5 2008/12/01 14:46:11 voyageur Exp $
+
+*pidgin-msn-pecan-0.0.17 (01 Dec 2008)
+
+ 01 Dec 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +pidgin-msn-pecan-0.0.17.ebuild:
+ Version bump, adds custom emoticon sending support and independent
+ personal status messages
*pidgin-msn-pecan-0.0.16 (14 Sep 2008)
diff --git a/x11-plugins/pidgin-msn-pecan/pidgin-msn-pecan-0.0.17.ebuild b/x11-plugins/pidgin-msn-pecan/pidgin-msn-pecan-0.0.17.ebuild
new file mode 100644
index 000000000000..0e1212ab59d6
--- /dev/null
+++ b/x11-plugins/pidgin-msn-pecan/pidgin-msn-pecan-0.0.17.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-msn-pecan/pidgin-msn-pecan-0.0.17.ebuild,v 1.1 2008/12/01 14:46:11 voyageur Exp $
+
+inherit toolchain-funcs multilib
+
+MY_P="msn-pecan-${PV}"
+
+DESCRIPTION="Alternative MSN protocol plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/msn-pecan/"
+
+SRC_URI="http://msn-pecan.googlecode.com/files/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:/lib:/$(get_libdir):" Makefile || die "unable to fix Makefile"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc COPYRIGHT ChangeLog README TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Select the 'WLM' protocol to use this plugin"
+ einfo
+ elog "For more information (how to change personal message, add"
+ elog "missing emoticons, ...), please read:"
+ elog "http://code.google.com/p/msn-pecan/wiki/FAQ"
+}