summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-05-04 15:53:52 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-05-04 15:53:52 +0000
commit2e3403fe1dfbcf6b0f437506b7b1a19b766b6357 (patch)
tree6c132ed9ae8985ea272901cad8bdddd4815609ff /x11-plugins
parentManifest fix (diff)
downloadgentoo-2-2e3403fe1dfbcf6b0f437506b7b1a19b766b6357.tar.gz
gentoo-2-2e3403fe1dfbcf6b0f437506b7b1a19b766b6357.tar.bz2
gentoo-2-2e3403fe1dfbcf6b0f437506b7b1a19b766b6357.zip
initial import by Manuel Rueger (mrueg) wrt #414171
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-opensteamworks/ChangeLog11
-rw-r--r--x11-plugins/pidgin-opensteamworks/Manifest5
-rw-r--r--x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.0_p30-Makefile29
-rw-r--r--x11-plugins/pidgin-opensteamworks/metadata.xml22
-rw-r--r--x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p30.ebuild31
5 files changed, 98 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-opensteamworks/ChangeLog b/x11-plugins/pidgin-opensteamworks/ChangeLog
new file mode 100644
index 000000000000..330a9e9ec639
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-plugins/pidgin-opensteamworks
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.1 2012/05/04 15:53:52 hasufell Exp $
+
+*pidgin-opensteamworks-1.0_p30 (04 May 2012)
+
+ 04 May 2012; Julian Ospald <hasufell@gentoo.org>
+ +pidgin-opensteamworks-1.0_p30.ebuild,
+ +files/pidgin-opensteamworks-1.0_p30-Makefile, +metadata.xml:
+ initial import by Manuel Rueger (mrueg) wrt #414171
+
diff --git a/x11-plugins/pidgin-opensteamworks/Manifest b/x11-plugins/pidgin-opensteamworks/Manifest
new file mode 100644
index 000000000000..1cbe153b05fb
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/Manifest
@@ -0,0 +1,5 @@
+AUX pidgin-opensteamworks-1.0_p30-Makefile 627 RMD160 269b229a8e744c332f91e6bea22d261782537cbd SHA1 f84680d5f23b74fb5661a718992509bb72a9f613 SHA256 862fa0e775c895ca0f11145d847fcb104f2f3fc9b6efda0416e255537c3d3663
+DIST pidgin-opensteamworks-1.0_p30.tar.xz 13648 RMD160 16b7f167177ce2246e16fa03653285680720c342 SHA1 4fa211fe934d6b0a0177597f393465dc50fa0687 SHA256 44f0be09f39abedb1130c01c8730fab2d0ad49d679111831605e88530d12d8cb
+EBUILD pidgin-opensteamworks-1.0_p30.ebuild 661 RMD160 31a1271d8b247abc698c72e2dd1745a5a57dff00 SHA1 019af243f53a04a2ff203f2554b34fd3d76a0011 SHA256 be9f6ecb02c26581d53342e58cc31a52b383ad0a54f5ff4128f7a93af491d3cb
+MISC ChangeLog 391 RMD160 044b7115ec2376ebd2e9ecf26a3179e62ec37a36 SHA1 af1a3fb778111f150478c3f77999ac0703a548fe SHA256 5173484f9dde14ec53b18e04042dc89fe5a28b6433ad44a7bf57e80c4407d928
+MISC metadata.xml 800 RMD160 d357199a8db4aabd449990301c66703232f0bbf0 SHA1 a14e1b58240017ac2a4113591bd946c1392dec09 SHA256 9309c3d38d80232690adbaae0b10894b9b9027c622c63e09f15fd4ed7784eebe
diff --git a/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.0_p30-Makefile b/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.0_p30-Makefile
new file mode 100644
index 000000000000..1b1489df6532
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.0_p30-Makefile
@@ -0,0 +1,29 @@
+CC ?= gcc
+
+PLUGINDIR ?= $(shell pkg-config --variable=plugindir purple)
+
+CFLAGS += -Wall -fPIC
+LDFLAGS += -shared
+CPPFLAGS += $(shell pkg-config --cflags glib-2.0 json-glib-1.0 purple)
+LIBS += $(shell pkg-config --libs glib-2.0 json-glib-1.0 purple)
+
+TARGET = libsteam.so
+
+OBJS = libsteam.o steam_connection.o
+
+%.o: %.c %.h
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $*.c
+
+$(TARGET): $(OBJS)
+ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJS) $(LIBS)
+
+install: $(TARGET)
+ @install -Dm755 $(TARGET) "$(DESTDIR)$(PLUGINDIR)/$(TARGET)"
+
+uninstall:
+ @rm -f "$(DESTDIR)$(PLUGINDIR)/$(TARGET)"
+
+clean:
+ @rm -f $(OBJS) $(TARGET)
+
+.PHONY: uninstall clean
diff --git a/x11-plugins/pidgin-opensteamworks/metadata.xml b/x11-plugins/pidgin-opensteamworks/metadata.xml
new file mode 100644
index 000000000000..4227f04871b7
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>gentoo@rueg.eu</email>
+ <name>Manuel Rüger</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>eionrobb@gmail.com</email>
+ </maintainer>
+ <changelog>http://ignorantguru.github.com/spacefm/news.html</changelog>
+ <doc lang="en">https://github.com/IgnorantGuru/spacefm/wiki/</doc>
+ <bugs-to>http://code.google.com/p/pidgin-opensteamworks/issues/list</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p30.ebuild b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p30.ebuild
new file mode 100644
index 000000000000..4f8d5da8d8c7
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p30.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p30.ebuild,v 1.1 2012/05/04 15:53:52 hasufell Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Steam protocol plugin for pidgin"
+HOMEPAGE="http://code.google.com/p/pidgin-opensteamworks/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ net-im/pidgin"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ # see http://code.google.com/p/pidgin-opensteamworks/issues/detail?id=31
+ cp "${FILESDIR}"/${P}-Makefile "${S}"/Makefile || die
+}