summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-24 19:19:06 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-24 19:19:06 +0000
commit281c33e278b32bb6f921f16984ca95589f846252 (patch)
tree83ecb591f5ab55474a8569478289cd03efa4f9dc /x11-plugins
parentInitial add of ebuild to portage. Please see bug #5984 (diff)
downloadgentoo-2-281c33e278b32bb6f921f16984ca95589f846252.tar.gz
gentoo-2-281c33e278b32bb6f921f16984ca95589f846252.tar.bz2
gentoo-2-281c33e278b32bb6f921f16984ca95589f846252.zip
Initial add of ebuild to portage. See bug #5986
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmfire/ChangeLog12
-rw-r--r--x11-plugins/wmfire/files/digest-wmfire-0.0.3.9_pre41
-rw-r--r--x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild37
3 files changed, 50 insertions, 0 deletions
diff --git a/x11-plugins/wmfire/ChangeLog b/x11-plugins/wmfire/ChangeLog
new file mode 100644
index 000000000000..3f0067e2b376
--- /dev/null
+++ b/x11-plugins/wmfire/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for x11-misc/wmfire
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfire/ChangeLog,v 1.1 2002/10/24 19:19:06 raker Exp $
+
+*wmfire-0.0.3.9_pre4 (4-Aug-2002)
+
+ 24 Oct 2002; Nick Hadaway <raker@gentoo.org>
+ wmfire-0.0.3.9_pre4.ebuild, files/digest-wmfire-0.0.3.9_pre4 :
+ Initial add of ebuild to portage
+
+ 4 Aug 2002; Matthew Schlegel <nitehawk-gentoo@1ststep.net> :
+ First version of the package.
diff --git a/x11-plugins/wmfire/files/digest-wmfire-0.0.3.9_pre4 b/x11-plugins/wmfire/files/digest-wmfire-0.0.3.9_pre4
new file mode 100644
index 000000000000..2b226d9bc73e
--- /dev/null
+++ b/x11-plugins/wmfire/files/digest-wmfire-0.0.3.9_pre4
@@ -0,0 +1 @@
+MD5 a5ea7e73041494dae95eba058d55cab1 wmfire-0.0.3.9pre4.tar.gz 69853
diff --git a/x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild b/x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild
new file mode 100644
index 000000000000..2be46dfd42d6
--- /dev/null
+++ b/x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild,v 1.1 2002/10/24 19:19:06 raker Exp $
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="WindowMaker dockapp that displays cpu usage as a dancing flame"
+SRC_URI="http://staff.xmms.org/zinx/misc/${MY_P}.tar.gz"
+HOMEPAGE="http://staff.xmms.org/zinx/misc"
+
+DEPEND="virtual/x11 x11-wm/WindowMaker virtual/glibc"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+IUSE=""
+
+src_compile() {
+
+ local myconf="--with-x";
+ econf ${myconf} || die "configure failed"
+
+ emake CFLAGS="$CFLAGS" || die "parallel make faile"
+}
+
+src_install () {
+
+ make install \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib || die
+
+ dodoc AUTHORS COPYING CREDITS INSTALL NEWS README
+
+}