summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-16 08:54:11 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-16 08:54:11 +0000
commit0c3d0dea94cbf4c3cce4a99d6f9dc1eeb4be93af (patch)
tree4dbb12b7c810be93d73c9eb9bac7a06f0bd4897d /x11-plugins
parentRemove unused patch (diff)
downloadgentoo-2-0c3d0dea94cbf4c3cce4a99d6f9dc1eeb4be93af.tar.gz
gentoo-2-0c3d0dea94cbf4c3cce4a99d6f9dc1eeb4be93af.tar.bz2
gentoo-2-0c3d0dea94cbf4c3cce4a99d6f9dc1eeb4be93af.zip
Fix disabling spell support and migrate to EAPI 2 in order to get rid of built_with_use. Fixes bug #263439.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/purple-plugin_pack/ChangeLog9
-rw-r--r--x11-plugins/purple-plugin_pack/purple-plugin_pack-2.5.1-r1.ebuild57
2 files changed, 65 insertions, 1 deletions
diff --git a/x11-plugins/purple-plugin_pack/ChangeLog b/x11-plugins/purple-plugin_pack/ChangeLog
index e81c78493e32..c864cf2c19d7 100644
--- a/x11-plugins/purple-plugin_pack/ChangeLog
+++ b/x11-plugins/purple-plugin_pack/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/purple-plugin_pack
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/purple-plugin_pack/ChangeLog,v 1.20 2009/01/05 05:46:53 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/purple-plugin_pack/ChangeLog,v 1.21 2009/08/16 08:54:11 betelgeuse Exp $
+
+*purple-plugin_pack-2.5.1-r1 (16 Aug 2009)
+
+ 16 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
+ +purple-plugin_pack-2.5.1-r1.ebuild:
+ Fix disabling spell support and migrate to EAPI 2 in order to get rid of
+ built_with_use. Fixes bug #263439.
05 Jan 2009; Olivier Crête <tester@gentoo.org>
purple-plugin_pack-2.5.1.ebuild:
diff --git a/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.5.1-r1.ebuild b/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..f673a1848272
--- /dev/null
+++ b/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.5.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/purple-plugin_pack/purple-plugin_pack-2.5.1-r1.ebuild,v 1.1 2009/08/16 08:54:11 betelgeuse Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A package with many different plugins for pidgin and libpurple"
+HOMEPAGE="http://plugins.guifications.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="talkfilters debug gtk ncurses spell"
+
+RDEPEND="net-im/pidgin[gtk?,ncurses?]
+ talkfilters? ( app-text/talkfilters )
+ spell? ( app-text/gtkspell )"
+DEPEND="${RDEPEND}
+ dev-lang/python"
+
+src_configure() {
+ local plugins=""
+
+ # XMMS Remote is disabled due to XMMS being masked
+ DISABLED_PLUGINS="xmmsremote"
+
+ use talkfilters || DISABLED_PLUGINS="${DISABLED_PLUGINS} talkfilters"
+ use spell || DISABLED_PLUGINS="${DISABLED_PLUGINS} switchspell"
+
+ plugins="$(python plugin_pack.py -p dist_dirs)"
+ use gtk && plugins="${plugins} $(python plugin_pack.py -P dist_dirs)"
+ use ncurses && plugins="${plugins} $(python plugin_pack.py -f dist_dirs)"
+
+ # Disable incomplete plugins too
+ DISABLED_PLUGINS="${DISABLED_PLUGINS} $(python plugin_pack.py -i dist_dirs)"
+
+ for i in $DISABLED_PLUGINS; do
+ plugins="${plugins//$i/}"
+ plugins="${plugins// / }"
+ plugins="${plugins/# /}"
+ plugins="${plugins/% /}"
+ echo disabled $i
+ echo $plugins
+ done
+
+ plugins="${plugins// /,}"
+
+ econf --with-plugins="${plugins}" $(use_enable debug) || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README VERSION || die
+}