summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-08-18 10:31:30 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-08-18 10:31:30 +0000
commited4313f277f2e06dfa52dec28ad2fda1dc979c82 (patch)
tree6c360d1ee3647c0f24ab641cf43b8afc25774787 /x11-plugins/wmnd
parentSet the correct win32 dll path, bug #197236 (diff)
downloadgentoo-2-ed4313f277f2e06dfa52dec28ad2fda1dc979c82.tar.gz
gentoo-2-ed4313f277f2e06dfa52dec28ad2fda1dc979c82.tar.bz2
gentoo-2-ed4313f277f2e06dfa52dec28ad2fda1dc979c82.zip
Version bump, hopefully fixing bug #214747. Updated HOMEPAGE and SRC_URI.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins/wmnd')
-rw-r--r--x11-plugins/wmnd/ChangeLog9
-rw-r--r--x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild10
-rw-r--r--x11-plugins/wmnd/wmnd-0.4.13.ebuild40
3 files changed, 53 insertions, 6 deletions
diff --git a/x11-plugins/wmnd/ChangeLog b/x11-plugins/wmnd/ChangeLog
index aa893e08331e..8d8ac05d3d05 100644
--- a/x11-plugins/wmnd/ChangeLog
+++ b/x11-plugins/wmnd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/wmnd
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnd/ChangeLog,v 1.41 2007/07/22 04:46:01 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnd/ChangeLog,v 1.42 2008/08/18 10:31:30 s4t4n Exp $
+
+*wmnd-0.4.13 (18 Aug 2008)
+
+ 18 Aug 2008; Michele Noberasco <s4t4n@gentoo.org> wmnd-0.4.3.ebuild:
+ Version bump, hopefully fixing bug #214747.
+ wmnd-0.4.11-r1.ebuild:
+ Updated HOMEPAGE and SRC_URI.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; wmnd-0.4.11.ebuild,
wmnd-0.4.11-r1.ebuild:
diff --git a/x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild b/x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild
index a6589cea0f7b..9e281e4ba50a 100644
--- a/x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild
+++ b/x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild,v 1.8 2007/07/22 04:46:01 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnd/wmnd-0.4.11-r1.ebuild,v 1.9 2008/08/18 10:31:30 s4t4n Exp $
IUSE="snmp"
DESCRIPTION="WindowMaker Network Devices (dockapp)"
-HOMEPAGE="http://www.yuv.info/wmnd/"
-SRC_URI="ftp://ftp.yuv.info/pub/wmnd/releases/${P}.tar.gz"
+HOMEPAGE="http://www.thregr.org/~wavexx/software/wmnd/"
+SRC_URI="http://www.thregr.org/~wavexx/software/wmnd/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -36,5 +36,5 @@ src_install()
dodoc README AUTHORS ChangeLog NEWS TODO
# gpl.info is no valid .info file. Causes errors with install-info.
- rm -r ${D}/usr/share/info
+ rm -r "${D}"/usr/share/info
}
diff --git a/x11-plugins/wmnd/wmnd-0.4.13.ebuild b/x11-plugins/wmnd/wmnd-0.4.13.ebuild
new file mode 100644
index 000000000000..33c3e5737ffd
--- /dev/null
+++ b/x11-plugins/wmnd/wmnd-0.4.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmnd/wmnd-0.4.13.ebuild,v 1.1 2008/08/18 10:31:30 s4t4n Exp $
+
+IUSE="snmp"
+DESCRIPTION="WindowMaker Network Devices (dockapp)"
+HOMEPAGE="http://www.thregr.org/~wavexx/software/wmnd/"
+SRC_URI="http://www.thregr.org/~wavexx/software/wmnd/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ snmp? ( >=net-analyzer/net-snmp-5.2.1 )"
+
+src_compile()
+{
+ if use snmp; then
+ LDFLAGS="$LDFLAGS -lcrypto"
+ fi
+
+ LDFLAGS="$LDFLAGS" econf || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install()
+{
+ einstall || die "make install failed"
+
+ dodoc README AUTHORS ChangeLog NEWS TODO
+
+ # gpl.info is no valid .info file. Causes errors with install-info.
+ rm -r "${D}"/usr/share/info
+}