summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-05-19 19:11:04 +0000
committerDane Smith <c1pher@gentoo.org>2011-05-19 19:11:04 +0000
commit2cd6e11c6ca2ee6e8f1b45cff17482256e192129 (patch)
tree3dce55876aeaed0df83f693a1a1223de7cd98942 /x11-plugins/wmlpq/files
parentAdd perl-5.14.0 as provider. Change version scheme. Force stable keywords (diff)
downloadgentoo-2-2cd6e11c6ca2ee6e8f1b45cff17482256e192129.tar.gz
gentoo-2-2cd6e11c6ca2ee6e8f1b45cff17482256e192129.tar.bz2
gentoo-2-2cd6e11c6ca2ee6e8f1b45cff17482256e192129.zip
x11-plugins/wmlpq: Revbump. Fix respect for toolchain. Fix respect for LDFLAGS wrt bug 351012.
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmlpq/files')
-rw-r--r--x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch b/x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch
new file mode 100644
index 000000000000..308e7f4e687e
--- /dev/null
+++ b/x11-plugins/wmlpq/files/wmlpq-makefile-ldflags.patch
@@ -0,0 +1,30 @@
+--- /Makefile.orig 2009-01-16 17:01:47.000000000 +0100
++++ /Makefile 2009-01-16 17:04:18.000000000 +0100
+@@ -2,11 +2,11 @@
+ CPPFLAGS = -I/usr/X11R6/include -I/usr/local/include
+ LIBS = -lXpm -lX11 -ldockapp
+ LDFLAGS = -L/usr/X11R6/lib -L/usr/local/lib
+-CFLAGS = -O2 -Wall
++CFLAGS = -Wall
+ DFLAGS = -ggdb3 -Wall
++DESTDIR = /usr/bin/
+
+ wmlpq: wmlpq.c wmlpq-master.xpm
+- cc $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) -o wmlpq $(LIBS) wmlpq.c
++ $(CC) $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) wmlpq.c -o wmlpq $(LIBS)
+- strip wmlpq
+
+ debug: wmlpq.c wmlpq-master.xpm
+@@ -18,10 +19,8 @@
+ rm -f wmlpq
+
+ install: wmlpq
+- cp -f wmlpq /usr/local/bin/
+- chmod 755 /usr/local/bin/wmlpq
+- cp -f wmlpq.1x /usr/local/man/man1/
+- chmod 644 /usr/local/man/man1/wmlpq.1x
++ cp -f wmlpq ${DESTDIR}
++ chmod 755 ${DESTDIR}/wmlpq
+
+ install-debian: wmlpq
+ cp -f wmlpq $(prefix)/usr/X11R6/bin/