summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-03-29 14:07:30 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-03-29 14:07:30 +0000
commitde6d590fc5fe7f6cc100ad3b21afcd97c4948d98 (patch)
tree8f0e2d2fe1b794cd79b849c6fa6a75513c607efb /x11-plugins/wmgtemp
parentstable x86, security bug 308049 (diff)
downloadgentoo-2-de6d590fc5fe7f6cc100ad3b21afcd97c4948d98.tar.gz
gentoo-2-de6d590fc5fe7f6cc100ad3b21afcd97c4948d98.tar.bz2
gentoo-2-de6d590fc5fe7f6cc100ad3b21afcd97c4948d98.zip
Version bump. See bug #291426.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/wmgtemp')
-rw-r--r--x11-plugins/wmgtemp/ChangeLog7
-rw-r--r--x11-plugins/wmgtemp/wmgtemp-1.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/x11-plugins/wmgtemp/ChangeLog b/x11-plugins/wmgtemp/ChangeLog
index b20a2491f551..5a21fc2231d0 100644
--- a/x11-plugins/wmgtemp/ChangeLog
+++ b/x11-plugins/wmgtemp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmgtemp
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmgtemp/ChangeLog,v 1.14 2010/01/19 11:18:26 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmgtemp/ChangeLog,v 1.15 2010/03/29 14:07:30 s4t4n Exp $
+
+*wmgtemp-1.0 (29 Mar 2010)
+
+ 29 Mar 2010; Michele Noberasco <s4t4n@gentoo.org> wmgtemp-1.0.ebuild:
+ Version bump. See bug #291426.
19 Jan 2010; Michele Noberasco <s4t4n@gentoo.org>; wmgtemp-0.1.ebuild:
Restrict lm_sensors version to <3.
diff --git a/x11-plugins/wmgtemp/wmgtemp-1.0.ebuild b/x11-plugins/wmgtemp/wmgtemp-1.0.ebuild
new file mode 100644
index 000000000000..ad3c4630b46a
--- /dev/null
+++ b/x11-plugins/wmgtemp/wmgtemp-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmgtemp/wmgtemp-1.0.ebuild,v 1.1 2010/03/29 14:07:30 s4t4n Exp $
+
+inherit eutils
+
+
+DESCRIPTION="CPU and SYS temperature dockapp"
+HOMEPAGE="http://www.fluxcode.net"
+SRC_URI="http://www.fluxcode.net/${P}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ =sys-apps/lm_sensors-3*
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:-Wall -g:\$(CFLAGS):" src/Makefile \
+ || die "sed failed."
+}
+
+src_compile() {
+ emake || die "emake failed."
+}
+
+src_install() {
+ dodoc BUGS CREDITS README TODO
+ dobin src/wmgtemp
+ doman wmgtemp.1
+}