summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2013-12-16 08:27:58 +0000
committerIan Whyman <thev00d00@gentoo.org>2013-12-16 08:27:58 +0000
commit82c3f8f34345ddd7de1ed95e824e172bcd6faf88 (patch)
treed94ed63a88b9d5b889ce21ab6e4e28ae98be9b35 /x11-plugins/pidgin-sipe
parentFix to compile with newer libmemcached per patch by Allen Parker <infowolfe@g... (diff)
downloadgentoo-2-82c3f8f34345ddd7de1ed95e824e172bcd6faf88.tar.gz
gentoo-2-82c3f8f34345ddd7de1ed95e824e172bcd6faf88.tar.bz2
gentoo-2-82c3f8f34345ddd7de1ed95e824e172bcd6faf88.zip
Version bump to 1.17.2, thanks to AW for #493812
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-plugins/pidgin-sipe')
-rw-r--r--x11-plugins/pidgin-sipe/ChangeLog7
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.17.2.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-sipe/ChangeLog b/x11-plugins/pidgin-sipe/ChangeLog
index 2401780f4b7f..f1ea767f7fd1 100644
--- a/x11-plugins/pidgin-sipe/ChangeLog
+++ b/x11-plugins/pidgin-sipe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/pidgin-sipe
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.23 2013/11/28 15:51:34 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.24 2013/12/16 08:27:58 thev00d00 Exp $
+
+*pidgin-sipe-1.17.2 (16 Dec 2013)
+
+ 16 Dec 2013; Ian Whyman <thev00d00@gentoo.org> +pidgin-sipe-1.17.2.ebuild:
+ Version bump to 1.17.2, thanks to AW for #493812
28 Nov 2013; Ian Whyman <thev00d00@gentoo.org> -pidgin-sipe-1.16.1.ebuild,
metadata.xml, pidgin-sipe-1.17.1.ebuild:
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.17.2.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.17.2.ebuild
new file mode 100644
index 000000000000..fe8f94534a1b
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.17.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/pidgin-sipe-1.17.2.ebuild,v 1.1 2013/12/16 08:27:58 thev00d00 Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kerberos ocs2005-message-hack telepathy voice"
+
+RDEPEND=">=dev-libs/gmime-2.4.16
+ dev-libs/libxml2
+ dev-libs/nss
+ kerberos? ( virtual/krb5 )
+ voice? (
+ >=dev-libs/glib-2.28.0
+ >=net-libs/libnice-0.1.0
+ media-libs/gstreamer:0.10
+ >=net-im/pidgin-2.8.0[gnutls]
+ )
+ !voice? (
+ >=dev-libs/glib-2.12.0:2
+ net-im/pidgin[gnutls]
+ )
+ telepathy? (
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.61
+ >=dev-libs/glib-2.28:2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+"
+
+DEPEND="dev-util/intltool
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.13.2-fix-sandbox-r1.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-purple \
+ --disable-quality-check \
+ $(use_enable telepathy) \
+ $(use_enable debug) \
+ $(use_enable ocs2005-message-hack) \
+ $(use_with kerberos krb5) \
+ $(use_with voice vv)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS TODO README
+}