summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-11-27 02:07:26 +0000
committerDon Seiler <rizzo@gentoo.org>2004-11-27 02:07:26 +0000
commitbc20b1d9fc716de6c99f4f4019e3eec05be86e40 (patch)
tree47c914465d8a6576b976890827973c6a088dd923 /x11-plugins/gaim-encryption
parentFixed manpage installation. (Manifest recommit) (diff)
downloadgentoo-2-bc20b1d9fc716de6c99f4f4019e3eec05be86e40.tar.gz
gentoo-2-bc20b1d9fc716de6c99f4f4019e3eec05be86e40.tar.bz2
gentoo-2-bc20b1d9fc716de6c99f4f4019e3eec05be86e40.zip
Revision bump to handle nspr install dir change, closes bug #72531
Diffstat (limited to 'x11-plugins/gaim-encryption')
-rw-r--r--x11-plugins/gaim-encryption/ChangeLog8
-rw-r--r--x11-plugins/gaim-encryption/Manifest2
-rw-r--r--x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.32-r11
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild40
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild3
5 files changed, 52 insertions, 2 deletions
diff --git a/x11-plugins/gaim-encryption/ChangeLog b/x11-plugins/gaim-encryption/ChangeLog
index 6351886aeee7..11b65e456e42 100644
--- a/x11-plugins/gaim-encryption/ChangeLog
+++ b/x11-plugins/gaim-encryption/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/gaim-encryption
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/ChangeLog,v 1.41 2004/11/15 20:02:01 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/ChangeLog,v 1.42 2004/11/27 02:07:26 rizzo Exp $
+
+*gaim-encryption-2.32-r1 (26 Nov 2004)
+
+ 26 Nov 2004; Don Seiler <rizzo@gentoo.org>
+ +gaim-encryption-2.32-r1.ebuild, gaim-encryption-2.32.ebuild:
+ Revision bump to handle nspr install dir change, closes bug #72531
15 Nov 2004; Markus Rothe <corsair@gentoo.org> gaim-encryption-2.32.ebuild:
Marked ~ppc64; bug #58170
diff --git a/x11-plugins/gaim-encryption/Manifest b/x11-plugins/gaim-encryption/Manifest
index e288d1f91eca..d0d7953fc848 100644
--- a/x11-plugins/gaim-encryption/Manifest
+++ b/x11-plugins/gaim-encryption/Manifest
@@ -1,4 +1,6 @@
MD5 21ef071e5b27c887ca8c01e36608b402 ChangeLog 9135
MD5 c63997d503b6a459715ebd4026f20e26 gaim-encryption-2.32.ebuild 1102
MD5 ab7db4bf9ff48c8de9da14fd12f6c15c metadata.xml 344
+MD5 597f1b04f100465a9bca26a078884af0 gaim-encryption-2.32-r1.ebuild 1107
+MD5 ff64a30a61d21ad47aab6594e4b1325b files/digest-gaim-encryption-2.32-r1 72
MD5 ff64a30a61d21ad47aab6594e4b1325b files/digest-gaim-encryption-2.32 72
diff --git a/x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.32-r1 b/x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.32-r1
new file mode 100644
index 000000000000..73f4b5573c95
--- /dev/null
+++ b/x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.32-r1
@@ -0,0 +1 @@
+MD5 708563eab2af9ed9fa71f556a140d67b gaim-encryption-2.32.tar.gz 521370
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild
new file mode 100644
index 000000000000..edeb07b63c3c
--- /dev/null
+++ b/x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-2.32-r1.ebuild,v 1.1 2004/11/27 02:07:26 rizzo Exp $
+
+inherit flag-o-matic eutils debug
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~ppc64"
+IUSE=""
+
+DEPEND=">=net-im/gaim-1.0.1
+ >=dev-libs/nspr-4.4.1-r2
+ dev-libs/nss"
+
+src_compile() {
+ local myconf
+
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}/nspr"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}/nss"
+
+ econf ${myconf} || die "Configuration failed"
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ emake || emake -j1 || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild
index 046b74b7e8ff..42836fddbd73 100644
--- a/x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild
+++ b/x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild,v 1.12 2004/11/15 20:02:01 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild,v 1.13 2004/11/27 02:07:26 rizzo Exp $
inherit flag-o-matic eutils debug
@@ -14,6 +14,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 mips ppc sparc x86 ~ppc64"
IUSE=""
DEPEND=">=net-im/gaim-1.0.1
+ <dev-libs/nspr-4.4.1-r2
dev-libs/nss"
src_compile() {