summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-07-21 19:31:56 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-07-21 19:31:56 +0000
commit9d0fdc2b48edb67c8fc4263d4e292957bfac7ffc (patch)
tree3a3925a79e61583510303dc42c0b63c291118628 /x11-misc
parentAdded license (diff)
downloadgentoo-2-9d0fdc2b48edb67c8fc4263d4e292957bfac7ffc.tar.gz
gentoo-2-9d0fdc2b48edb67c8fc4263d4e292957bfac7ffc.tar.bz2
gentoo-2-9d0fdc2b48edb67c8fc4263d4e292957bfac7ffc.zip
Fixed ebuild.
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mgm/mgm-1.1.ebuild36
-rw-r--r--x11-misc/xloadimage/ChangeLog2
-rw-r--r--x11-misc/xloadimage/xloadimage-4.1.ebuild33
3 files changed, 29 insertions, 42 deletions
diff --git a/x11-misc/mgm/mgm-1.1.ebuild b/x11-misc/mgm/mgm-1.1.ebuild
index 02d2a277561f..fdfb1ae5a478 100644
--- a/x11-misc/mgm/mgm-1.1.ebuild
+++ b/x11-misc/mgm/mgm-1.1.ebuild
@@ -1,3 +1,7 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/mgm/mgm-1.1.ebuild,v 1.2 2002/07/21 19:31:56 aliz Exp $
+
DESCRIPTION="ORNAMENTVM ROSACEVM INFERNVM PRATVLIS"
HOMEPAGE="http://www.xiph.org/mgm/index.html"
SRC_URI="http://www.xiph.org/mgm/${P}.tgz"
@@ -5,31 +9,29 @@ S=${WORKDIR}/${PN}
KEYWORDS="x86"
SLOT="0"
-LICENSE=""
+LICENSE="as-is"
RDEPEND=">=sys-devel/perl-5.6.1
- >=dev-perl/perl-tk-800.024"
+ >=dev-perl/perl-tk-800.024"
src_unpack()
{
- unpack ${P}.tgz
-
- cd ${S}
- patch < ${FILESDIR}/${P}-gentoo.patch
+ unpack ${P}.tgz
+ cd ${S}
+ patch < ${FILESDIR}/${P}-gentoo.patch
}
src_install()
{
- cd ${S}
-
- dobin mgm
- dohtml doc/*
- insinto usr/share/mgm
- doins lib/*
- insinto usr/share/mgm/linux
- doins modules/linux/*
- insinto usr/share/mgm/share
- doins modules/share/*
-
+ cd ${S}
+
+ dobin mgm
+ dohtml doc/*
+ insinto usr/share/mgm
+ doins lib/*
+ insinto usr/share/mgm/linux
+ doins modules/linux/*
+ insinto usr/share/mgm/share
+ doins modules/share/*
}
diff --git a/x11-misc/xloadimage/ChangeLog b/x11-misc/xloadimage/ChangeLog
index c2b3aa06cab9..e303e455978b 100644
--- a/x11-misc/xloadimage/ChangeLog
+++ b/x11-misc/xloadimage/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for x11-misc/xloadimage
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.4 2002/05/30 01:54:49 sandymac Exp
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xloadimage/ChangeLog,v 1.2 2002/07/21 19:29:27 aliz Exp $
*xloadimage-4.1 (19 Jul 2002)
diff --git a/x11-misc/xloadimage/xloadimage-4.1.ebuild b/x11-misc/xloadimage/xloadimage-4.1.ebuild
index 0d0ef342c518..49fdc5883e0d 100644
--- a/x11-misc/xloadimage/xloadimage-4.1.ebuild
+++ b/x11-misc/xloadimage/xloadimage-4.1.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.8 2002/05/30 01:54:49 sandymac Exp
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xloadimage/xloadimage-4.1.ebuild,v 1.2 2002/07/21 19:29:38 aliz Exp $
A=xloadimage.${PV}
S=${WORKDIR}/${A}
DESCRIPTION="Xloadimage is a utility which will view many different types of images under X11"
SRC_URI="ftp://ftp.x.org/R5contrib/${A}.tar.gz"
HOMEPAGE="http://gopher.std.com/homepages/jimf/xloadimage.html"
-LICENSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="x86"
DEPEND="x11-base/xfree
tiff? ( media-libs/tiff )
png? ( media-libs/libpng )
@@ -22,32 +24,16 @@ src_unpack() {
cp Make.conf Make.conf.orig
sed -e "s:OPT_FLAGS=:OPT_FLAGS=$CFLAGS:" Make.conf.orig >Make.conf
-# use jpeg && \
-# cp Make.conf Make.conf.orig
-# sed -e "s:OPTIONAL_SRCS=:OPTIONAL_SRCS=jpeg.c :" \
-# -e "s:OPTIONAL_LIBS=:OPTIONAL_LIBS=jpeg/libjpeg.a :" \
-# -e "s:CC_FLAGS=:CC_FLAGS=-DHAS_JPEG :" Make.conf.orig >Make.conf
-#
-# use tiff && \
-# cp Make.conf Make.conf.orig
-# sed -e "s:OPTIONAL_SRCS=:OPTIONAL_SRCS=tiff.c :" \
-# -e "s:OPTIONAL_LIBS=:OPTIONAL_LIBS=tiff/libtiff.a :" \
-# -e "s:CC_FLAGS=:CC_FLAGS=-DHAS_TIFF :" Make.conf.orig >Make.conf
-
}
src_compile() {
-
chmod 0755 configure
./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
-
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
-
- #emake || die
make || die
}
@@ -58,7 +44,7 @@ src_install () {
dobin uufilter
insinto /etc/X11
- doins xloadimagerc
+ doins xloadimagerc
mv xloadimage.man xloadimage.1
mv uufilter.man uufilter.1
@@ -70,5 +56,4 @@ src_install () {
dosym /usr/share/man/man1/xloadimage.1.gz /usr/share/man/man1/xview.1.gz
dodoc README
-
}