summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2007-07-03 19:06:46 +0000
committerSven Wegener <swegener@gentoo.org>2007-07-03 19:06:46 +0000
commit87f2a5a5b2dbc7114113fbedba2c80eafbe61679 (patch)
tree940db06d0946353d19a9d3c7915879cc69b3fc91 /x11-misc
parentRemove redundant functions. (diff)
downloadgentoo-2-87f2a5a5b2dbc7114113fbedba2c80eafbe61679.tar.gz
gentoo-2-87f2a5a5b2dbc7114113fbedba2c80eafbe61679.tar.bz2
gentoo-2-87f2a5a5b2dbc7114113fbedba2c80eafbe61679.zip
Force thread support on when building against our system libvncserver.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/x11vnc/ChangeLog5
-rw-r--r--x11-misc/x11vnc/x11vnc-0.9.2-r1.ebuild8
2 files changed, 11 insertions, 2 deletions
diff --git a/x11-misc/x11vnc/ChangeLog b/x11-misc/x11vnc/ChangeLog
index 3c3a0086c3d5..56f4bd7d991f 100644
--- a/x11-misc/x11vnc/ChangeLog
+++ b/x11-misc/x11vnc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/x11vnc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.39 2007/06/25 14:28:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/ChangeLog,v 1.40 2007/07/03 19:06:46 swegener Exp $
+
+ 03 Jul 2007; Sven Wegener <swegener@gentoo.org> x11vnc-0.9.2-r1.ebuild:
+ Force thread support on when building against our system libvncserver.
25 Jun 2007; Raúl Porcel <armin76@gentoo.org> x11vnc-0.9.1.ebuild:
ia64/x86 stable
diff --git a/x11-misc/x11vnc/x11vnc-0.9.2-r1.ebuild b/x11-misc/x11vnc/x11vnc-0.9.2-r1.ebuild
index d6b11f7d5a74..79bd30aa25e2 100644
--- a/x11-misc/x11vnc/x11vnc-0.9.2-r1.ebuild
+++ b/x11-misc/x11vnc/x11vnc-0.9.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.2-r1.ebuild,v 1.2 2007/06/24 23:42:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/x11vnc/x11vnc-0.9.2-r1.ebuild,v 1.3 2007/07/03 19:06:46 swegener Exp $
DESCRIPTION="A VNC server for real X displays"
HOMEPAGE="http://www.karlrunge.com/x11vnc/"
@@ -43,6 +43,11 @@ DEPEND="${RDEPEND}
)"
src_compile() {
+ local myconf=""
+
+ # we need to force threads on, because our system libvncserver gets build with thread support
+ use system-libvncserver && myconf="--with-pthread"
+
econf \
$(use_with system-libvncserver) \
$(use_with avahi) \
@@ -54,6 +59,7 @@ src_compile() {
$(use_with jpeg) \
$(use_with zlib) \
$(use_with threads pthread) \
+ ${myconf} \
|| die "econf failed"
emake || die "emake failed"
}