summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2006-12-23 00:38:55 +0000
committerRyan Hill <dirtyepic@gentoo.org>2006-12-23 00:38:55 +0000
commit614c33567dce4694e05b64cd7cdc5468676ccac1 (patch)
treef5ab03baca5c9ace9106e236644e547984bd06f9 /x11-misc
parentAdd ALSA_CARDS default copied from x86. (diff)
downloadgentoo-2-614c33567dce4694e05b64cd7cdc5468676ccac1.tar.gz
gentoo-2-614c33567dce4694e05b64cd7cdc5468676ccac1.tar.bz2
gentoo-2-614c33567dce4694e05b64cd7cdc5468676ccac1.zip
Version bump. wxGTK 2.8 friendly, plus image printing should be working again.
(Portage version: 2.1.2_rc3-r5)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xchm/ChangeLog7
-rw-r--r--x11-misc/xchm/files/digest-xchm-1.103
-rw-r--r--x11-misc/xchm/xchm-1.10.ebuild65
3 files changed, 74 insertions, 1 deletions
diff --git a/x11-misc/xchm/ChangeLog b/x11-misc/xchm/ChangeLog
index 3d95938aca45..799618de8752 100644
--- a/x11-misc/xchm/ChangeLog
+++ b/x11-misc/xchm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xchm
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/ChangeLog,v 1.40 2006/10/14 17:09:45 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/ChangeLog,v 1.41 2006/12/23 00:38:54 dirtyepic Exp $
+
+*xchm-1.10 (23 Dec 2006)
+
+ 23 Dec 2006; Ryan Hill <dirtyepic@gentoo.org> +xchm-1.10.ebuild:
+ Version bump. wxGTK 2.8 friendly, plus image printing should be working again.
14 Oct 2006; Krzysiek Pawlik <nelchael@gentoo.org> -xchm-1.3.ebuild,
-xchm-1.7.1.ebuild:
diff --git a/x11-misc/xchm/files/digest-xchm-1.10 b/x11-misc/xchm/files/digest-xchm-1.10
new file mode 100644
index 000000000000..c2adfe0148b6
--- /dev/null
+++ b/x11-misc/xchm/files/digest-xchm-1.10
@@ -0,0 +1,3 @@
+MD5 df4d42e3bb11187139f4475b89c4ab96 xchm-1.10.tar.gz 371871
+RMD160 b7f556c4755cb1aa5097e4865e07404af8b4c203 xchm-1.10.tar.gz 371871
+SHA256 dbed9ed4df515f4035c8c881ff72203cbc1ef697640eeb876267be469343a524 xchm-1.10.tar.gz 371871
diff --git a/x11-misc/xchm/xchm-1.10.ebuild b/x11-misc/xchm/xchm-1.10.ebuild
new file mode 100644
index 000000000000..270dcb319c61
--- /dev/null
+++ b/x11-misc/xchm/xchm-1.10.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/xchm-1.10.ebuild,v 1.1 2006/12/23 00:38:54 dirtyepic Exp $
+
+inherit wxwidgets
+
+DESCRIPTION="Utility for viewing Microsoft .chm files."
+HOMEPAGE="http://xchm.sf.net"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="unicode"
+DEPEND=">=app-doc/chmlib-0.31
+ >=x11-libs/wxGTK-2.6.0"
+
+src_compile() {
+ local myconf
+ export WX_GTK_VER="2.6"
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+ myconf="${myconf} --with-wx-config=${WX_CONFIG}"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS README
+
+ # fixes desktop and icon problems
+ rm ${D}/usr/share/pixmaps/xchm-*.xpm
+ ${D}/usr/share/pixmaps/xchmdoc-*.xpm
+
+ dodir /usr/share/icons/hicolor/16x16/apps/
+ install -m 644 ${S}/art/xchm-16.xpm \
+ ${D}/usr/share/icons/hicolor/16x16/apps/xchm.xpm
+ dodir /usr/share/icons/hicolor/32x32/apps/
+ install -m 644 ${S}/art/xchm-32.xpm \
+ ${D}/usr/share/icons/hicolor/32x32/apps/xchm.xpm
+ dodir /usr/share/icons/hicolor/48x48/apps/
+ install -m 644 ${S}/art/xchm-48.xpm \
+ ${D}/usr/share/icons/hicolor/48x48/apps/xchm.xpm
+ dodir /usr/share/icons/hicolor/128x128/apps/
+ install -m 644 ${S}/art/xchm-128.xpm \
+ ${D}/usr/share/icons/hicolor/128x128/apps/xchm.xpm
+ dodir /usr/share/icons/hicolor/16x16/mimetypes/
+ install -m 644 ${S}/art/xchmdoc-16.xpm \
+ ${D}/usr/share/icons/hicolor/16x16/mimetypes/chm.xpm
+ dodir /usr/share/icons/hicolor/32x32/mimetypes/
+ install -m 644 ${S}/art/xchmdoc-32.xpm \
+ ${D}/usr/share/icons/hicolor/32x32/mimetypes/chm.xpm
+ dodir /usr/share/icons/hicolor/48x48/mimetypes/
+ install -m 644 ${S}/art/xchmdoc-48.xpm \
+ ${D}/usr/share/icons/hicolor/48x48/mimetypes/chm.xpm
+ dodir /usr/share/icons/hicolor/128x128/mimetypes/
+ install -m 644 ${S}/art/xchmdoc-128.xpm \
+ ${D}/usr/share/icons/hicolor/128x128/mimetypes/chm.xpm
+ make_desktop_entry xchm XCHM xchm
+}