summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-03 00:25:13 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-03 00:25:13 +0000
commit5d3afe7ee0365acfc37e7b2c2c3399a50f07f3bf (patch)
treef50ef3c3dd1c9ad98c660415a3f0de2bbaf3821a /x11-misc
parentQt category move. (diff)
downloadgentoo-2-5d3afe7ee0365acfc37e7b2c2c3399a50f07f3bf.tar.gz
gentoo-2-5d3afe7ee0365acfc37e7b2c2c3399a50f07f3bf.tar.bz2
gentoo-2-5d3afe7ee0365acfc37e7b2c2c3399a50f07f3bf.zip
fix locale behavior, add missing PYTHON_USEDEP to dependencies, remove unsupported python2_5, remove obsolete PYTHON_MODNAME variable, update license
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/arandr/ChangeLog10
-rw-r--r--x11-misc/arandr/arandr-0.1.7-r1.ebuild40
-rw-r--r--x11-misc/arandr/arandr-0.1.7.ebuild39
-rw-r--r--x11-misc/arandr/files/arandr-0.1.7-locale.patch27
4 files changed, 76 insertions, 40 deletions
diff --git a/x11-misc/arandr/ChangeLog b/x11-misc/arandr/ChangeLog
index ced059ec32f8..1710ee028633 100644
--- a/x11-misc/arandr/ChangeLog
+++ b/x11-misc/arandr/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-misc/arandr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/arandr/ChangeLog,v 1.10 2013/03/01 18:13:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/arandr/ChangeLog,v 1.11 2013/03/03 00:25:13 hasufell Exp $
+
+*arandr-0.1.7-r1 (03 Mar 2013)
+
+ 03 Mar 2013; Julian Ospald <hasufell@gentoo.org> -arandr-0.1.7.ebuild,
+ +arandr-0.1.7-r1.ebuild, +files/arandr-0.1.7-locale.patch:
+ fix locale behavior, add missing PYTHON_USEDEP to dependencies, remove
+ unsupported python2_5, remove obsolete PYTHON_MODNAME variable, update
+ license
01 Mar 2013; Jeroen Roovers <jer@gentoo.org> arandr-0.1.7.ebuild:
Port to distutils-r1.
diff --git a/x11-misc/arandr/arandr-0.1.7-r1.ebuild b/x11-misc/arandr/arandr-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..30b3f8c7d765
--- /dev/null
+++ b/x11-misc/arandr/arandr-0.1.7-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/arandr/arandr-0.1.7-r1.ebuild,v 1.1 2013/03/03 00:25:13 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A simple visual frontend for XRandR 1.2/1.3"
+HOMEPAGE="http://christian.amsuess.com/tools/arandr/"
+SRC_URI="http://christian.amsuess.com/tools/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygtk-2[${PYTHON_USEDEP}]
+ x11-apps/xrandr"
+DEPEND=">=dev-python/docutils-0.6[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-locale.patch
+
+ local i p
+ # simulate gettext behavior:
+ # LINGUAS unset => install all
+ # LINGUAS="" => install none
+ # LINGUAS="de fr" => install de and fr
+ if [[ -n "${LINGUAS+x}" ]] ; then # if LINGUAS is set
+ for i in $(cd "${S}"/data/po ; for p in *.po ; do echo ${p%.po} ; done) ; do # for every supported language
+ if ! has ${i} ${LINGUAS} ; then # if language is disabled
+ rm data/po/${i}.po || die
+ fi
+ done
+ fi
+ distutils-r1_src_prepare
+}
diff --git a/x11-misc/arandr/arandr-0.1.7.ebuild b/x11-misc/arandr/arandr-0.1.7.ebuild
deleted file mode 100644
index eb245f34b03c..000000000000
--- a/x11-misc/arandr/arandr-0.1.7.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/arandr/arandr-0.1.7.ebuild,v 1.2 2013/03/01 18:13:51 jer Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-inherit distutils-r1
-
-DESCRIPTION="A simple visual frontend for XRandR 1.2/1.3"
-HOMEPAGE="http://christian.amsuess.com/tools/arandr/"
-SRC_URI="http://christian.amsuess.com/tools/${PN}/files/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ARANDR_LINGUAS=(
- ar br bs ca da de el es fa fr gl hu it ja kn ko_KR lt nl pl pt_BR ro ru sk
- sv tr uk zh_CN
-)
-
-IUSE+=" ${ARANDR_LINGUAS[@]/#/linguas_}"
-
-RDEPEND=">=dev-python/pygtk-2
- x11-apps/xrandr"
-DEPEND=">=dev-python/docutils-0.6"
-
-PYTHON_MODNAME=screenlayout
-
-src_prepare() {
- local lingua
- for lingua in ${ARANDR_LINGUAS[@]}; do
- if ! use linguas_${lingua}; then
- rm data/po/${lingua}.po || die
- fi
- done
- distutils-r1_src_prepare
-}
diff --git a/x11-misc/arandr/files/arandr-0.1.7-locale.patch b/x11-misc/arandr/files/arandr-0.1.7-locale.patch
new file mode 100644
index 000000000000..9954f4ea7f57
--- /dev/null
+++ b/x11-misc/arandr/files/arandr-0.1.7-locale.patch
@@ -0,0 +1,27 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Mar 3 00:09:56 UTC 2013
+Subject: build system
+
+don't error out when build/locale is non-existent
+
+--- arandr-0.1.7/setup.py
++++ arandr-0.1.7/setup.py
+@@ -120,12 +120,13 @@
+
+ class install_data(_install_data):
+ def run(self):
+- for lang in os.listdir('build/locale/'):
+- lang_dir = os.path.join('share', 'locale', lang, 'LC_MESSAGES')
+- lang_file = os.path.join('build', 'locale', lang, 'LC_MESSAGES', 'arandr.mo')
+- self.data_files.append((lang_dir, [lang_file]))
++ if (os.path.exists('build/locale/')):
++ for lang in os.listdir('build/locale/'):
++ lang_dir = os.path.join('share', 'locale', lang, 'LC_MESSAGES')
++ lang_file = os.path.join('build', 'locale', lang, 'LC_MESSAGES', 'arandr.mo')
++ self.data_files.append((lang_dir, [lang_file]))
+
+- _install_data.run(self)
++ _install_data.run(self)
+
+ class sdist(_sdist):
+ def run(self):