summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-03-14 18:27:39 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-03-14 18:27:39 +0000
commit5917c79ebc813a3a97c0ddb0d9ec8ee449e963a7 (patch)
tree25fdf181eb4f49051cff1b8431ba236dee313b9e /x11-misc
parentversion bump (diff)
downloadgentoo-2-5917c79ebc813a3a97c0ddb0d9ec8ee449e963a7.tar.gz
gentoo-2-5917c79ebc813a3a97c0ddb0d9ec8ee449e963a7.tar.bz2
gentoo-2-5917c79ebc813a3a97c0ddb0d9ec8ee449e963a7.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/magneto-gtk/ChangeLog9
-rw-r--r--x11-misc/magneto-gtk/magneto-gtk-183.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/x11-misc/magneto-gtk/ChangeLog b/x11-misc/magneto-gtk/ChangeLog
index 6dc37b526da2..0c6eb37acd9a 100644
--- a/x11-misc/magneto-gtk/ChangeLog
+++ b/x11-misc/magneto-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/magneto-gtk
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/magneto-gtk/ChangeLog,v 1.31 2012/09/27 11:05:22 lxnay Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/magneto-gtk/ChangeLog,v 1.32 2013/03/14 18:27:39 lxnay Exp $
+
+*magneto-gtk-183 (14 Mar 2013)
+
+ 14 Mar 2013; Fabio Erculiani <lxnay@gentoo.org> +magneto-gtk-183.ebuild:
+ version bump
*magneto-gtk-144 (27 Sep 2012)
diff --git a/x11-misc/magneto-gtk/magneto-gtk-183.ebuild b/x11-misc/magneto-gtk/magneto-gtk-183.ebuild
new file mode 100644
index 000000000000..0e61ae0b93b1
--- /dev/null
+++ b/x11-misc/magneto-gtk/magneto-gtk-183.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/magneto-gtk/magneto-gtk-183.ebuild,v 1.1 2013/03/14 18:27:39 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager notification applet GTK2 frontend"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+RDEPEND="~app-misc/magneto-loader-${PV}
+ dev-python/notify-python
+ dev-python/pygtk:2
+"
+DEPEND=""
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-gtk-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/magneto/magneto/gtk"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/magneto/magneto/gtk"
+}