summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-07-30 21:49:08 +0000
committerMichael Weber <xmw@gentoo.org>2014-07-30 21:49:08 +0000
commit402ac376851d60d326df93e110d480bd92448d3a (patch)
tree23c3ca0f86fdd69bfad922cd3ca08b71ebf19eb7 /x11-misc
parentWhitespace (diff)
downloadgentoo-2-402ac376851d60d326df93e110d480bd92448d3a.tar.gz
gentoo-2-402ac376851d60d326df93e110d480bd92448d3a.tar.bz2
gentoo-2-402ac376851d60d326df93e110d480bd92448d3a.zip
Version bump (euscan).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/trayer-srg/ChangeLog10
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild32
2 files changed, 39 insertions, 3 deletions
diff --git a/x11-misc/trayer-srg/ChangeLog b/x11-misc/trayer-srg/ChangeLog
index 02f9ab2635ec..b7090b5618db 100644
--- a/x11-misc/trayer-srg/ChangeLog
+++ b/x11-misc/trayer-srg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/trayer-srg
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/trayer-srg/ChangeLog,v 1.11 2012/12/11 23:29:00 xmw Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/trayer-srg/ChangeLog,v 1.12 2014/07/30 21:49:08 xmw Exp $
+
+*trayer-srg-1.1.6 (30 Jul 2014)
+
+ 30 Jul 2014; Michael Weber <xmw@gentoo.org> +trayer-srg-1.1.6.ebuild:
+ Version bump (euscan).
11 Dec 2012; Michael Weber <xmw@gentoo.org> -trayer-srg-1.1.4.ebuild:
Drop old
@@ -41,4 +46,3 @@
29 Jan 2012; Michael Weber <xmw@gentoo.org> +trayer-srg-1.1.4.ebuild,
+metadata.xml:
Initial import (from xmw overlay)
-
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild
new file mode 100644
index 000000000000..a9b39b0cecbe
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/trayer-srg/trayer-srg-1.1.6.ebuild,v 1.1 2014/07/30 21:49:08 xmw Exp $
+
+EAPI=4
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="trayer fork with multi monitor support, cleaned up codebase and other fancy stuff"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/tarball/${P/-srg/} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc CHANGELOG CREDITS README TODO
+}