summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2005-05-19 03:58:03 +0000
committerBryan Stine <battousai@gentoo.org>2005-05-19 03:58:03 +0000
commit1dfe051f97ce4f2e24e214289f6ce0512ae98ffd (patch)
tree08375521ddd65e4b94f83e7e4557725682238edf /x11-misc
parentRemove invalid PROVIDE. (diff)
downloadgentoo-2-1dfe051f97ce4f2e24e214289f6ce0512ae98ffd.tar.gz
gentoo-2-1dfe051f97ce4f2e24e214289f6ce0512ae98ffd.tar.bz2
gentoo-2-1dfe051f97ce4f2e24e214289f6ce0512ae98ffd.zip
Bump to 0.14.2. Closes bug #93092.
(Portage version: 2.0.51.21)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/synaptics/ChangeLog7
-rw-r--r--x11-misc/synaptics/files/digest-synaptics-0.14.21
-rw-r--r--x11-misc/synaptics/synaptics-0.14.2.ebuild45
3 files changed, 52 insertions, 1 deletions
diff --git a/x11-misc/synaptics/ChangeLog b/x11-misc/synaptics/ChangeLog
index ed5bc4e92854..f09a9ec9fc06 100644
--- a/x11-misc/synaptics/ChangeLog
+++ b/x11-misc/synaptics/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/synaptics
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/ChangeLog,v 1.37 2005/04/25 06:13:24 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/ChangeLog,v 1.38 2005/05/19 03:58:03 battousai Exp $
+
+*synaptics-0.14.2 (19 May 2005)
+
+ 19 May 2005; Bryan Stine <battousai@gentoo.org> +synaptics-0.14.2.ebuild:
+ Bump to 0.14.2. Thanks to Benjamin Smee for reporting. Closes bug #93092.
25 Apr 2005; Donnie Berkholz <spyderous@gentoo.org>; metadata.xml:
Update herd to x11-drivers.
diff --git a/x11-misc/synaptics/files/digest-synaptics-0.14.2 b/x11-misc/synaptics/files/digest-synaptics-0.14.2
new file mode 100644
index 000000000000..cedab874961d
--- /dev/null
+++ b/x11-misc/synaptics/files/digest-synaptics-0.14.2
@@ -0,0 +1 @@
+MD5 2058ade25ed47b15d7772d1b3c628222 synaptics-0.14.2.tar.bz2 122336
diff --git a/x11-misc/synaptics/synaptics-0.14.2.ebuild b/x11-misc/synaptics/synaptics-0.14.2.ebuild
new file mode 100644
index 000000000000..1c60907591ac
--- /dev/null
+++ b/x11-misc/synaptics/synaptics-0.14.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synaptics/synaptics-0.14.2.ebuild,v 1.1 2005/05/19 03:58:03 battousai Exp $
+
+inherit toolchain-funcs eutils
+
+# This ebuild overwrites synaptics files installed by <= xfree-4.3.0-r6
+# and xfree-4.3.99.14 >= X >= xfree-4.3.99.8.
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://w1.894.telia.com/~u89404340/touchpad/"
+SRC_URI="http://w1.894.telia.com/~u89404340/touchpad/files/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND="virtual/x11"
+DEPEND=">=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Put stuff into /usr/X11R6, also switch up the CC and CFLAGS stuff.
+ sed -i -e "s:BINDIR = \\\$(DESTDIR)/usr/local/bin:BINDIR = ${D}/usr/X11R6/bin:g" ${S}/Makefile
+ sed -i -e "s:CC = gcc:CC = $(tc-getCC):g" ${S}/Makefile
+ sed -i -e "s:CDEBUGFLAGS = -O2:CDEBUGFLAGS = ${CFLAGS}:g" ${S}/Makefile
+ sed -i -e "s:MANDIR = .*:MANDIR = \\\$(DESTDIR)/usr/man/man1:" ${S}/Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodir /usr/X11R6/{bin,lib/modules/input}
+
+ # Yes, they got the DESTDIR stuff going. And there was much rejoicing.
+ make DESTDIR=${D} install || die
+ dodoc {script/usbmouse,alps.patch,COMPATIBILITY,FILES,INSTALL{,.DE},LICENSE,NEWS,TODO,README{,.alps}}
+ # Stupid new daemon, didn't work for me because of shm issues
+ exeinto /etc/init.d && newexe ${FILESDIR}/rc.init syndaemon
+ insinto /etc/conf.d && newins ${FILESDIR}/rc.conf syndaemon
+}