summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2005-06-05 14:18:13 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2005-06-05 14:18:13 +0000
commitb984d0af8dadc60cea4641ea8dcc25a1957c3132 (patch)
treea50059d359f6e59b1848d3574096473fe0ab3d33 /x11-misc/xwit
parentRemoved trailing whitespaces. (diff)
downloadgentoo-2-b984d0af8dadc60cea4641ea8dcc25a1957c3132.tar.gz
gentoo-2-b984d0af8dadc60cea4641ea8dcc25a1957c3132.tar.bz2
gentoo-2-b984d0af8dadc60cea4641ea8dcc25a1957c3132.zip
Fixed bug #82626.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-misc/xwit')
-rw-r--r--x11-misc/xwit/ChangeLog8
-rw-r--r--x11-misc/xwit/files/malloc.patch11
-rw-r--r--x11-misc/xwit/xwit-3.4.ebuild8
3 files changed, 23 insertions, 4 deletions
diff --git a/x11-misc/xwit/ChangeLog b/x11-misc/xwit/ChangeLog
index fc792e738256..4e857120c991 100644
--- a/x11-misc/xwit/ChangeLog
+++ b/x11-misc/xwit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xwit
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/ChangeLog,v 1.3 2004/06/24 22:46:44 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/ChangeLog,v 1.4 2005/06/05 14:18:13 pyrania Exp $
+
+ 05 Jun 2005; Markus Nigbur <pyrania@gentoo.org> +files/malloc.patch,
+ xwit-3.4.ebuild:
+ Fixed bug #82626.
11 Apr 2004; Markus Nigbur <pyrania@gentoo.org> xwit-3.4.ebuild:
Marked stable.
diff --git a/x11-misc/xwit/files/malloc.patch b/x11-misc/xwit/files/malloc.patch
new file mode 100644
index 000000000000..41c3a7b82eff
--- /dev/null
+++ b/x11-misc/xwit/files/malloc.patch
@@ -0,0 +1,11 @@
+--- dsimple.c_ 2005-06-05 16:07:10.000000000 +0200
++++ dsimple.c 2005-06-05 16:07:47.000000000 +0200
+@@ -46,7 +46,7 @@
+ char *Malloc(size)
+ unsigned size;
+ {
+- char *data, *malloc();
++ char *data; //, *malloc();
+
+ if (!(data = malloc(size)))
+ Fatal_Error("Out of memory!");
diff --git a/x11-misc/xwit/xwit-3.4.ebuild b/x11-misc/xwit/xwit-3.4.ebuild
index 5bbab688adf8..8b38cc48d8ea 100644
--- a/x11-misc/xwit/xwit-3.4.ebuild
+++ b/x11-misc/xwit/xwit-3.4.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/xwit-3.4.ebuild,v 1.3 2004/06/24 22:46:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xwit/xwit-3.4.ebuild,v 1.4 2005/06/05 14:18:13 pyrania Exp $
+
+inherit eutils
IUSE=""
@@ -15,6 +17,8 @@ KEYWORDS="x86"
DEPEND="virtual/x11"
src_compile() {
+ epatch ${FILESDIR}/malloc.patch
+
xmkmf || die "xmkmf failed"
emake || die "Make failed"
}