summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-02-11 16:04:45 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-02-11 16:04:45 +0000
commit2b4b841a6e473cb7b90a690fe1296cd0fa3e35f3 (patch)
tree0e93b8dec4fce8ad900c0bbb35523137e7111b7f /x11-misc/xlockmore
parentVersion bumped. Added some USE flags. (diff)
downloadgentoo-2-2b4b841a6e473cb7b90a690fe1296cd0fa3e35f3.tar.gz
gentoo-2-2b4b841a6e473cb7b90a690fe1296cd0fa3e35f3.tar.bz2
gentoo-2-2b4b841a6e473cb7b90a690fe1296cd0fa3e35f3.zip
Readded 5.17-r1, shouldn't be removed yet.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'x11-misc/xlockmore')
-rw-r--r--x11-misc/xlockmore/ChangeLog6
-rw-r--r--x11-misc/xlockmore/files/digest-xlockmore-5.17-r11
-rw-r--r--x11-misc/xlockmore/xlockmore-5.17-r1.ebuild84
3 files changed, 90 insertions, 1 deletions
diff --git a/x11-misc/xlockmore/ChangeLog b/x11-misc/xlockmore/ChangeLog
index 605e3ee7690b..cfab559dfc64 100644
--- a/x11-misc/xlockmore/ChangeLog
+++ b/x11-misc/xlockmore/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xlockmore
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/ChangeLog,v 1.40 2006/02/11 09:58:59 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/ChangeLog,v 1.41 2006/02/11 16:04:45 nelchael Exp $
+
+ 11 Feb 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +xlockmore-5.17-r1.ebuild:
+ Readded 5.17-r1, shouldn't be removed yet.
11 Feb 2006; Krzysiek Pawlik <nelchael@gentoo.org>
-xlockmore-5.17-r1.ebuild:
diff --git a/x11-misc/xlockmore/files/digest-xlockmore-5.17-r1 b/x11-misc/xlockmore/files/digest-xlockmore-5.17-r1
new file mode 100644
index 000000000000..b2a1e08c2e90
--- /dev/null
+++ b/x11-misc/xlockmore/files/digest-xlockmore-5.17-r1
@@ -0,0 +1 @@
+MD5 3ebf62f611aab074c41aeae95231ce7f xlockmore-5.17.tar.bz2 1734958
diff --git a/x11-misc/xlockmore/xlockmore-5.17-r1.ebuild b/x11-misc/xlockmore/xlockmore-5.17-r1.ebuild
new file mode 100644
index 000000000000..7b8d12951aa4
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.17-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/xlockmore-5.17-r1.ebuild,v 1.10 2006/02/11 16:04:45 nelchael Exp $
+
+inherit gnuconfig eutils pam flag-o-matic
+
+IUSE="nas esd motif opengl truetype gtk pam xlockrc"
+
+DESCRIPTION="Just another screensaver application for X"
+SRC_URI="http://ftp.tux.org/pub/tux/bagleyd/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+RDEPEND="|| ( (
+ media-libs/mesa
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libXdmcp
+ x11-libs/libXt
+ x11-libs/libXpm )
+ virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/xineramaproto )
+ virtual/x11 )
+ media-libs/freetype
+ opengl? ( virtual/opengl )
+ pam? ( virtual/pam )
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+ motif? ( x11-libs/openmotif )
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+src_compile() {
+
+ local myconf
+
+ use xlockrc && myconf="${myconf} --enable-xlockrc"
+ use opengl || myconf="${myconf} --without-opengl --without-gltt --without-mesa"
+
+ econf \
+ --sharedstatedir=${D}/usr/share/xlockmore \
+ --enable-vtlock \
+ --without-ftgl \
+ $(use_enable pam) \
+ $(use_with truetype ttf) \
+ $(use_with gtk) \
+ $(use_with motif) \
+ $(use_with esd esound) \
+ $(use_with nas) \
+ ${myconf} \
+ || die "econf failed"
+
+ # fixes suid-with-lazy-bindings problem
+ append-flags '-Wl,-z,now'
+
+ emake || die "Make failed"
+
+}
+
+src_install() {
+ einstall \
+ xapploaddir=${D}/etc/X11/app-defaults \
+ mandir=${D}/usr/share/man/man1 \
+ || die "einstall failed"
+
+ #Install pam.d file and unset setuid root
+ pamd_mimic_system xlock auth
+ use pam && chmod 755 ${D}/usr/bin/xlock
+
+ insinto /usr/share/xlockmore/sounds
+ doins sounds/*
+
+ dodoc docs/* README
+ dohtml docs/*.html
+ rm ${D}/usr/share/doc/${PF}/*.html.gz
+}