summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2005-12-18 15:29:38 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2005-12-18 15:29:38 +0000
commit252da213144af230a8fb96146ff5d719c909521e (patch)
tree9872e7b57e0444d88f370e005bd9586812d2c331 /x11-misc/xfishtank
parentVersion bump (diff)
downloadgentoo-2-252da213144af230a8fb96146ff5d719c909521e.tar.gz
gentoo-2-252da213144af230a8fb96146ff5d719c909521e.tar.bz2
gentoo-2-252da213144af230a8fb96146ff5d719c909521e.zip
Fix Makefile to use CFLAGS (bug #115938).
(Portage version: 2.1_pre1)
Diffstat (limited to 'x11-misc/xfishtank')
-rw-r--r--x11-misc/xfishtank/ChangeLog6
-rw-r--r--x11-misc/xfishtank/Manifest3
-rw-r--r--x11-misc/xfishtank/files/xfishtank-2.1tp-Makefile.patch12
-rw-r--r--x11-misc/xfishtank/xfishtank-2.1.ebuild9
4 files changed, 27 insertions, 3 deletions
diff --git a/x11-misc/xfishtank/ChangeLog b/x11-misc/xfishtank/ChangeLog
index d61f67691443..299979d7f4cb 100644
--- a/x11-misc/xfishtank/ChangeLog
+++ b/x11-misc/xfishtank/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xfishtank
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfishtank/ChangeLog,v 1.8 2005/12/18 12:32:28 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfishtank/ChangeLog,v 1.9 2005/12/18 15:29:38 nelchael Exp $
+
+ 18 Dec 2005; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/xfishtank-2.1tp-Makefile.patch, xfishtank-2.1.ebuild:
+ Fix Makefile to use CFLAGS (bug #115938).
18 Dec 2005; Krzysiek Pawlik <nelchael@gentoo.org> xfishtank-2.1.ebuild:
Fix dodoc - bug #115860.
diff --git a/x11-misc/xfishtank/Manifest b/x11-misc/xfishtank/Manifest
index b2dfd90997f1..71568500dc72 100644
--- a/x11-misc/xfishtank/Manifest
+++ b/x11-misc/xfishtank/Manifest
@@ -1,4 +1,5 @@
MD5 bac35a55c99e17676caa35ae93fdc3f1 ChangeLog 956
MD5 f334f7ee0979c62671de0916bc4c7908 files/digest-xfishtank-2.1 67
+MD5 559fc2c6f75e887149cb9c1502480394 files/xfishtank-2.1tp-Makefile.patch 703
MD5 cdb11033a3fa6525334cecf938961c07 metadata.xml 166
-MD5 4efda7b642bd59ac11448a6817dc110c xfishtank-2.1.ebuild 711
+MD5 6213ed563ec8521ddfd7caa52ed01b30 xfishtank-2.1.ebuild 805
diff --git a/x11-misc/xfishtank/files/xfishtank-2.1tp-Makefile.patch b/x11-misc/xfishtank/files/xfishtank-2.1tp-Makefile.patch
new file mode 100644
index 000000000000..df404b1949b0
--- /dev/null
+++ b/x11-misc/xfishtank/files/xfishtank-2.1tp-Makefile.patch
@@ -0,0 +1,12 @@
+diff -Nru xfishtank-2.1tp.vanilla/Makefile xfishtank-2.1tp/Makefile
+--- xfishtank-2.1tp.vanilla/Makefile 2005-12-18 16:21:08.000000000 +0100
++++ xfishtank-2.1tp/Makefile 2005-12-18 16:23:06.000000000 +0100
+@@ -212,7 +212,7 @@
+
+ ALLINCLUDES = $(INCLUDES) $(EXTRA_INCLUDES) $(TOP_INCLUDES) $(STD_INCLUDES)
+ ALLDEFINES = $(ALLINCLUDES) $(STD_DEFINES) $(EXTRA_DEFINES) $(PROTO_DEFINES) $(THREADS_DEFINES) $(DEFINES)
+- CFLAGS = $(CDEBUGFLAGS) $(CCOPTIONS) $(THREADS_CFLAGS) $(ALLDEFINES)
++ CFLAGS += $(CCOPTIONS) $(THREADS_CFLAGS) $(ALLDEFINES)
+ LINTFLAGS = $(LINTOPTS) -DLINT $(ALLDEFINES) $(DEPEND_DEFINES)
+ LDPRELIB = -L$(USRLIBDIR)
+ LDPOSTLIB =
diff --git a/x11-misc/xfishtank/xfishtank-2.1.ebuild b/x11-misc/xfishtank/xfishtank-2.1.ebuild
index b9bf7adb0a23..e642d47289cb 100644
--- a/x11-misc/xfishtank/xfishtank-2.1.ebuild
+++ b/x11-misc/xfishtank/xfishtank-2.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfishtank/xfishtank-2.1.ebuild,v 1.8 2005/12/18 12:32:28 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfishtank/xfishtank-2.1.ebuild,v 1.9 2005/12/18 15:29:38 nelchael Exp $
+
+inherit eutils
DESCRIPTION="Turns your root window into an aquarium."
HOMEPAGE="http://www.ibiblio.org/pub/Linux/X11/demos/"
@@ -15,6 +17,11 @@ KEYWORDS="ppc ppc64 x86"
IUSE=""
DEPEND="virtual/x11"
+src_unpack() {
+ unpack "${A}"
+ epatch "${FILESDIR}/${MY_P}-Makefile.patch"
+}
+
src_compile() {
makedepend || die
emake || die