summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-17 01:43:34 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-17 01:43:34 +0000
commit1962eabfe62b4cb57ce23e376901774717e71b67 (patch)
treed200b0a03370aba52c66d4bbe4cc810e74500ca5 /x11-misc/xcb
parentClean up patches. (diff)
downloadgentoo-2-1962eabfe62b4cb57ce23e376901774717e71b67.tar.gz
gentoo-2-1962eabfe62b4cb57ce23e376901774717e71b67.tar.bz2
gentoo-2-1962eabfe62b4cb57ce23e376901774717e71b67.zip
Respect LDFLAGS (bug #337522), CPP, LDFLAGS.
(Portage version: 2.2_rc82/cvs/Linux i686)
Diffstat (limited to 'x11-misc/xcb')
-rw-r--r--x11-misc/xcb/ChangeLog9
-rw-r--r--x11-misc/xcb/xcb-2.4-r1.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/x11-misc/xcb/ChangeLog b/x11-misc/xcb/ChangeLog
index fcd9f10ce0b7..761060295063 100644
--- a/x11-misc/xcb/ChangeLog
+++ b/x11-misc/xcb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xcb
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcb/ChangeLog,v 1.13 2009/05/02 10:10:59 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcb/ChangeLog,v 1.14 2010/09/17 01:43:34 jer Exp $
+
+*xcb-2.4-r1 (17 Sep 2010)
+
+ 17 Sep 2010; Jeroen Roovers <jer@gentoo.org> +xcb-2.4-r1.ebuild:
+ Respect LDFLAGS (bug #337522), CPP, LDFLAGS.
02 May 2009; Samuli Suominen <ssuominen@gentoo.org> xcb-2.4.ebuild:
Install app-defaults to /usr/share instead of /usr/X11R6/lib and tc-export
diff --git a/x11-misc/xcb/xcb-2.4-r1.ebuild b/x11-misc/xcb/xcb-2.4-r1.ebuild
new file mode 100644
index 000000000000..55764b1c350a
--- /dev/null
+++ b/x11-misc/xcb/xcb-2.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xcb/xcb-2.4-r1.ebuild,v 1.1 2010/09/17 01:43:34 jer Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Marc Lehmann's improved X Cut Buffers"
+HOMEPAGE="http://www.goof.com/pcg/marc/xcb.html"
+SRC_URI="http://www.goof.com/pcg/marc/data/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="motif"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ motif? ( x11-libs/openmotif )"
+
+src_compile() {
+ local gui libs
+
+ if use motif; then
+ gui="-DMOTIF"
+ libs="-lXm -lXt -lX11"
+ else
+ gui="-DATHENA"
+ libs="-lXaw -lXt -lXext -lX11"
+ fi
+
+ emake -f Makefile.std xcb Xcb.ad \
+ CC=$(tc-getCC) \
+ CPP=$(tc-getCPP) \
+ CFLAGS="${CFLAGS} ${gui}" \
+ GUI="${gui}" \
+ LIBS="${libs}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin xcb || die "dobin failed"
+ newman xcb.man xcb.1
+ insinto /usr/share/X11/app-defaults
+ newins Xcb.ad Xcb || die "newins failed"
+}