summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-19 21:59:29 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-19 21:59:29 +0000
commitdaccd3f1397a793ee6c37bd97aeffee706e96d1d (patch)
treebd1b69886083af159969652c3ca23415876ebf88 /x11-misc/wmakerconf
parentelibtoolized (diff)
downloadgentoo-2-daccd3f1397a793ee6c37bd97aeffee706e96d1d.tar.gz
gentoo-2-daccd3f1397a793ee6c37bd97aeffee706e96d1d.tar.bz2
gentoo-2-daccd3f1397a793ee6c37bd97aeffee706e96d1d.zip
small fix0r
Diffstat (limited to 'x11-misc/wmakerconf')
-rw-r--r--x11-misc/wmakerconf/ChangeLog10
-rw-r--r--x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r21
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.8.1-r2.ebuild51
3 files changed, 61 insertions, 1 deletions
diff --git a/x11-misc/wmakerconf/ChangeLog b/x11-misc/wmakerconf/ChangeLog
index 5b2b727f5a1b..0797eb961320 100644
--- a/x11-misc/wmakerconf/ChangeLog
+++ b/x11-misc/wmakerconf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-misc/wmakerconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.1 2002/04/02 06:06:21 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.2 2002/06/19 21:59:29 seemant Exp $
+
+*wmakerconf-2.8.1-r2 (19 Jun 2002)
+
+ 19 Jun 2002; Seemant Kulleen <seemant@gentoo.org>
+ wmakerconf-2.8.1-r2.ebuild files/digest-wmakerconf-2.8.1-r2 :
+
+ Fixed bug #3909 by info@cs-ol.de (Udo Mu"ller) to make the Gnome1 DEPEND
+ listing a little cleaner.
*wmakerconf-2.8.1-r1
diff --git a/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r2 b/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r2
new file mode 100644
index 000000000000..f3b723c38256
--- /dev/null
+++ b/x11-misc/wmakerconf/files/digest-wmakerconf-2.8.1-r2
@@ -0,0 +1 @@
+MD5 03749f08953638ed2a0ab260a407d264 wmakerconf-2.8.1.tar.gz 666175
diff --git a/x11-misc/wmakerconf/wmakerconf-2.8.1-r2.ebuild b/x11-misc/wmakerconf/wmakerconf-2.8.1-r2.ebuild
new file mode 100644
index 000000000000..4824e6545e7f
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.8.1-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Joao Schim <joao@schim.net>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.8.1-r2.ebuild,v 1.1 2002/06/19 21:59:29 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X based config tool for the windowmaker X windowmanager."
+SRC_URI="http://wmaker.orcon.net.nz/current/${P}.tar.gz"
+HOMEPAGE="http://ulli.on.openave.net/wmakerconf/"
+SLOT="0"
+DEPEND="=x11-libs/gtk+-1.2*
+ x11-wm/WindowMaker
+ x11-libs/libPropList
+ gnome? ( =gnome-base/gnome-libs-1.4* )
+ imlib? ( media-libs/imlib )"
+
+
+RDEPEND="nls? ( sys-devel/gettext )
+ perl? ( sys-devel/perl
+ net-misc/wget )"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use imlib || myconf="${myconf} --disable-imlibtest"
+
+ use gnome || myconf="${myconf} --without-gnome"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --with-wmakerdataprefix=/usr/share \
+ --sysconfdir=/etc \
+ ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ GNOMEDIR=${D}/usr/share/gnome/apps/Settings \
+ install || die
+
+ dodoc README MANUAL AUTHORS TODO COPYING ChangeLog
+ dohtml -r .
+}