summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-06 12:26:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-06 12:26:27 +0000
commitd0e4c0317358d4b6cc4dacbd95e6e4f2e30cc025 (patch)
tree9569fd1cb3003d89fcf56559504d08494906731c /x11-misc/wmakerconf
parentRestore calls to python_mod_optimize() / python_mod_cleanup(). (diff)
downloadgentoo-2-d0e4c0317358d4b6cc4dacbd95e6e4f2e30cc025.tar.gz
gentoo-2-d0e4c0317358d4b6cc4dacbd95e6e4f2e30cc025.tar.bz2
gentoo-2-d0e4c0317358d4b6cc4dacbd95e6e4f2e30cc025.zip
Version bump wrt #237199 by Dustin Polke.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/wmakerconf')
-rw-r--r--x11-misc/wmakerconf/ChangeLog10
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.12.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/x11-misc/wmakerconf/ChangeLog b/x11-misc/wmakerconf/ChangeLog
index 6db4ae8bd11f..4f798ab18b6e 100644
--- a/x11-misc/wmakerconf/ChangeLog
+++ b/x11-misc/wmakerconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/wmakerconf
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.33 2008/05/06 13:44:09 drac Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.34 2010/06/06 12:26:27 ssuominen Exp $
+
+*wmakerconf-2.12 (06 Jun 2010)
+
+ 06 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +wmakerconf-2.12.ebuild:
+ Version bump wrt #237199 by Dustin Polke.
06 May 2008; Samuli Suominen <drac@gentoo.org> wmakerconf-2.11.ebuild:
Move pkgconfig to DEPEND wrt #217278.
diff --git a/x11-misc/wmakerconf/wmakerconf-2.12.ebuild b/x11-misc/wmakerconf/wmakerconf-2.12.ebuild
new file mode 100644
index 000000000000..b64b637b25d0
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.12.ebuild,v 1.1 2010/06/06 12:26:27 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="X based config tool for the windowmaker X windowmanager."
+HOMEPAGE="http://wmakerconf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="imlib nls perl"
+
+RDEPEND="x11-libs/gtk+:2
+ >=x11-wm/windowmaker-0.90.0
+ imlib? ( media-libs/imlib )
+ perl? ( dev-lang/perl
+ dev-perl/HTML-Parser
+ dev-perl/libwww-perl
+ www-client/lynx
+ net-misc/wget )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myconf
+ use imlib || myconf="--disable-imlibtest"
+
+ econf \
+ $(use_enable perl upgrade) \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" gnulocaledir="${D}/usr/share/locale" install || die
+ dodoc AUTHORS ChangeLog MANUAL NEWS README TODO
+ doman man/*.1
+
+ rm -f "${D}"/usr/share/${PN}/{AUTHORS,README,COPYING,NEWS,MANUAL,ABOUT-NLS,NLS-TEAM1,ChangeLog}
+}