summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <lamer@gentoo.org>2001-09-01 22:59:34 +0000
committerBen Lutgens <lamer@gentoo.org>2001-09-01 22:59:34 +0000
commit8f8cd494eed180ab35a49d51dfea5b9d27ce258e (patch)
treefa0367b06379519790f3c613d155670dade1e15b /x11-misc/ttmkfdir
parentdigests (diff)
downloadgentoo-2-8f8cd494eed180ab35a49d51dfea5b9d27ce258e.tar.gz
gentoo-2-8f8cd494eed180ab35a49d51dfea5b9d27ce258e.tar.bz2
gentoo-2-8f8cd494eed180ab35a49d51dfea5b9d27ce258e.zip
lots of fix0rs
Diffstat (limited to 'x11-misc/ttmkfdir')
-rw-r--r--x11-misc/ttmkfdir/files/digest-ttmkfdir-0.01
-rw-r--r--x11-misc/ttmkfdir/files/ttmkfdir-0.0-gentoo.diff46
-rw-r--r--x11-misc/ttmkfdir/ttmkfdir-0.0.ebuild30
3 files changed, 77 insertions, 0 deletions
diff --git a/x11-misc/ttmkfdir/files/digest-ttmkfdir-0.0 b/x11-misc/ttmkfdir/files/digest-ttmkfdir-0.0
new file mode 100644
index 000000000000..cc84f5dfe1dd
--- /dev/null
+++ b/x11-misc/ttmkfdir/files/digest-ttmkfdir-0.0
@@ -0,0 +1 @@
+MD5 dcf6aa4d28f5c52acf2bb57f49f53089 ttmkfdir.tar.gz
diff --git a/x11-misc/ttmkfdir/files/ttmkfdir-0.0-gentoo.diff b/x11-misc/ttmkfdir/files/ttmkfdir-0.0-gentoo.diff
new file mode 100644
index 000000000000..37d8f7055b68
--- /dev/null
+++ b/x11-misc/ttmkfdir/files/ttmkfdir-0.0-gentoo.diff
@@ -0,0 +1,46 @@
+diff -ur ttmkfdir.orig/Makefile ttmkfdir/Makefile
+--- ttmkfdir.orig/Makefile Thu Sep 10 12:54:26 1998
++++ ttmkfdir/Makefile Thu Mar 1 15:29:38 2001
+@@ -1,10 +1,11 @@
+-FREETYPE_BASE=../freetype-1.1
+-FREETYPE_INCL=$(FREETYPE_BASE)/lib
+-FREETYPE_LIB=-L$(FREETYPE_BASE)/lib/.libs -lttf
++FREETYPE_BASE=/usr
++FREETYPE_INCL=-I$(FREETYPE_BASE)/include
++FREETYPE_LIB=-L$(FREETYPE_BASE)/lib -lttf
+
+ CC=gcc
+-CFLAGS=-Wall -pedantic -I$(FREETYPE_INCL)
+-LDFALGS=$(FREETYPE_LIB) -s
++OPT=-O2
++CFLAGS=$(OPT) -Wall -pedantic $(FREETYPE_INCL)
++LDFLAGS=$(FREETYPE_LIB)
+
+ all: ttmkfdir
+
+@@ -18,7 +19,11 @@
+ ln $< $@
+
+ ttmkfdir: ttmkfdir.o
+- $(CC) -o $@ $< $(LDFALGS)
++ $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS)
++
++install: all
++ mkdir -p $(DESTDIR)/usr/X11R6/bin
++ install -c -m 755 ttmkfdir $(DESTDIR)/usr/X11R6/bin
+
+ ttmkfdir.o: ttmkfdir.c panose.h ttos2val.h
+
+Only in ttmkfdir: Makefile~
+diff -ur ttmkfdir.orig/ttmkfdir.c ttmkfdir/ttmkfdir.c
+--- ttmkfdir.orig/ttmkfdir.c Wed Sep 9 08:50:50 1998
++++ ttmkfdir/ttmkfdir.c Thu Mar 1 15:09:51 2001
+@@ -61,7 +61,7 @@
+ #include <ctype.h>
+ #include <errno.h>
+
+-#include <freetype.h>
++#include <freetype/freetype.h>
+
+ #include "panose.h"
+ #include "ttos2val.h"
diff --git a/x11-misc/ttmkfdir/ttmkfdir-0.0.ebuild b/x11-misc/ttmkfdir/ttmkfdir-0.0.ebuild
new file mode 100644
index 000000000000..b48c50d6b2d1
--- /dev/null
+++ b/x11-misc/ttmkfdir/ttmkfdir-0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pete@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/ttmkfdir/ttmkfdir-0.0.ebuild,v 1.1 2001/09/01 22:59:34 lamer Exp $
+
+#P=
+A=ttmkfdir.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="a utility to create a fonts.scale file from a set of TrueType fonts"
+SRC_URI="http://www.joerg-pommnitz.de/TrueType/ttmkfdir.tar.gz"
+HOMEPAGE="http://www.joerg-pommnitz.de/TrueType/xfsft.html"
+
+DEPEND="=media-libs/freetype-1.3.1-r2"
+
+src_unpack() {
+ mkdir ${P}
+ cd ${P}
+ unpack ${A}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ try make clean
+ try make OPT="${CFLAGS}"
+}
+
+src_install () {
+ try make DESTDIR=${D} install
+ dodoc README
+}