summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-07-23 15:09:00 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-07-23 15:09:00 +0000
commit0c63bbbc01a8973bbb35031f35bb4be579d7dd37 (patch)
treef46d9d3577ded07510e43e380cb862f0aeef098b /x11-misc/redshift
parentAdding optional dependency on selinux policies (diff)
downloadgentoo-2-0c63bbbc01a8973bbb35031f35bb4be579d7dd37.tar.gz
gentoo-2-0c63bbbc01a8973bbb35031f35bb4be579d7dd37.tar.bz2
gentoo-2-0c63bbbc01a8973bbb35031f35bb4be579d7dd37.zip
handle python-abi stuff without patch
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/redshift')
-rw-r--r--x11-misc/redshift/ChangeLog6
-rw-r--r--x11-misc/redshift/files/redshift-1.7-python-abi.patch30
-rw-r--r--x11-misc/redshift/redshift-1.7-r1.ebuild15
3 files changed, 11 insertions, 40 deletions
diff --git a/x11-misc/redshift/ChangeLog b/x11-misc/redshift/ChangeLog
index 5e2e76358ac9..92c3ec15e404 100644
--- a/x11-misc/redshift/ChangeLog
+++ b/x11-misc/redshift/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/redshift
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/redshift/ChangeLog,v 1.15 2012/07/21 19:13:55 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/redshift/ChangeLog,v 1.16 2012/07/23 15:08:59 hasufell Exp $
+
+ 23 Jul 2012; Julian Ospald <hasufell@gentoo.org> redshift-1.7-r1.ebuild,
+ -files/redshift-1.7-python-abi.patch:
+ handle python-abi stuff without patch
21 Jul 2012; Julian Ospald <hasufell@gentoo.org> redshift-1.7-r1.ebuild,
+files/redshift-1.7-python-abi.patch:
diff --git a/x11-misc/redshift/files/redshift-1.7-python-abi.patch b/x11-misc/redshift/files/redshift-1.7-python-abi.patch
deleted file mode 100644
index 34ed52faccbf..000000000000
--- a/x11-misc/redshift/files/redshift-1.7-python-abi.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Fri Jul 20 17:59:51 UTC 2012
-Subject: gentoo-specific patch to support multiple python abis
-
---- src/gtk-redshift/Makefile.am
-+++ src/gtk-redshift/Makefile.am
-@@ -1,21 +1,9 @@
-
--if ENABLE_GUI
--gtk_redshift_PYTHON = \
-- __init__.py \
-- utils.py \
-- statusicon.py
--nodist_gtk_redshift_PYTHON = \
-- defs.py
- gtk_redshiftdir = $(pythondir)/gtk_redshift
-
- dist_bin_SCRIPTS = gtk-redshift
--endif
--
--EXTRA_DIST = defs.py.in
--CLEANFILES = defs.py
--
-
- # Local python definitions
--defs.py: defs.py.in
-+all-local: defs.py.in
- sed -e "s|\@bindir\@|$(bindir)|g" \
-- -e "s|\@localedir\@|$(localedir)|g" $< > $@
-+ -e "s|\@localedir\@|$(localedir)|g" $< > defs.py
diff --git a/x11-misc/redshift/redshift-1.7-r1.ebuild b/x11-misc/redshift/redshift-1.7-r1.ebuild
index e2ff0c07dbd5..bbfad5969ff6 100644
--- a/x11-misc/redshift/redshift-1.7-r1.ebuild
+++ b/x11-misc/redshift/redshift-1.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/redshift/redshift-1.7-r1.ebuild,v 1.2 2012/07/21 19:13:55 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/redshift/redshift-1.7-r1.ebuild,v 1.3 2012/07/23 15:08:59 hasufell Exp $
EAPI=4
@@ -33,8 +33,7 @@ DEPEND="${COMMON_DEPEND}
src_prepare() {
>py-compile
- epatch "${FILESDIR}"/${P}-python-abi.patch \
- "${FILESDIR}"/${P}-make-conditionals.patch
+ epatch "${FILESDIR}"/${P}-make-conditionals.patch
eautoreconf
}
@@ -53,20 +52,18 @@ src_configure() {
src_install() {
default
+ rm -R "${D}"/usr/$(get_libdir)/python* || die
# handle multiple python abi support
per_abi_install() {
cp "${D}"/usr/bin/gtk-redshift "${D}"/usr/bin/gtk-redshift-${PYTHON_ABI} || die
- python_convert_shebangs ${PYTHON_ABI} "${D}"/usr/bin/gtk-redshift-${PYTHON_ABI}
-
- insinto "$(python_get_sitedir)"/gtk_redshift
- doins src/gtk-redshift/{__init__,defs,statusicon,utils}.py
+ python_convert_shebangs ${PYTHON_ABI} "${D}"/usr/bin/gtk-redshift-${PYTHON_ABI}
+ emake DESTDIR="${D}" pythondir="$(python_get_sitedir)" -C src/gtk-redshift install || die
}
if use gtk ; then
python_execute_function per_abi_install
- rm "${D}"/usr/bin/gtk-redshift || die
- python_generate_wrapper_scripts "${D}"/usr/bin/gtk-redshift
+ python_generate_wrapper_scripts -f "${D}"/usr/bin/gtk-redshift
fi
}