summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-10-19 12:21:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-10-19 12:21:09 +0000
commitd29f667b0b3d405276125d1a75b71a065f1cfc84 (patch)
treeeebc119bb326f9940a2b86cc2d4f5dcbdba690b9 /x11-misc/parcellite
parentadded ~ppc64 keyword wrt bug #488236 (diff)
downloadgentoo-2-d29f667b0b3d405276125d1a75b71a065f1cfc84.tar.gz
gentoo-2-d29f667b0b3d405276125d1a75b71a065f1cfc84.tar.bz2
gentoo-2-d29f667b0b3d405276125d1a75b71a065f1cfc84.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'x11-misc/parcellite')
-rw-r--r--x11-misc/parcellite/ChangeLog7
-rw-r--r--x11-misc/parcellite/parcellite-1.1.7.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/x11-misc/parcellite/ChangeLog b/x11-misc/parcellite/ChangeLog
index 16202fdd5b9c..f7e82cb52f0b 100644
--- a/x11-misc/parcellite/ChangeLog
+++ b/x11-misc/parcellite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/parcellite
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.29 2013/08/14 12:11:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.30 2013/10/19 12:21:09 hwoarang Exp $
+
+*parcellite-1.1.7 (19 Oct 2013)
+
+ 19 Oct 2013; Markos Chandras <hwoarang@gentoo.org> +parcellite-1.1.7.ebuild:
+ Version bump
*parcellite-1.1.6 (14 Aug 2013)
diff --git a/x11-misc/parcellite/parcellite-1.1.7.ebuild b/x11-misc/parcellite/parcellite-1.1.7.ebuild
new file mode 100644
index 000000000000..2385c16503f4
--- /dev/null
+++ b/x11-misc/parcellite/parcellite-1.1.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-1.1.7.ebuild,v 1.1 2013/10/19 12:21:09 hwoarang Exp $
+
+EAPI=5
+inherit eutils fdo-mime
+
+MY_P=${PN}-${PV/_}
+
+DESCRIPTION="A lightweight GTK+ based clipboard manager."
+HOMEPAGE="http://parcellite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.10:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i data/${PN}.desktop.in -e 's:Application;::g' || die
+
+ sed -i -e '/^ALL_LINGUAS=/d' configure || die
+ strip-linguas -i po/
+ export ALL_LINGUAS="${LINGUAS}"
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}