summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-06-14 01:29:48 +0000
committerJonathan Smith <smithj@gentoo.org>2005-06-14 01:29:48 +0000
commit4de288e9c71c9b08d183bd44f87b17f6a6793134 (patch)
treec5aff776f46c5756dc82dca369512992157707d1 /x11-misc/menumaker/menumaker-0.17.ebuild
parentAdded afterstep herd. (diff)
downloadgentoo-2-4de288e9c71c9b08d183bd44f87b17f6a6793134.tar.gz
gentoo-2-4de288e9c71c9b08d183bd44f87b17f6a6793134.tar.bz2
gentoo-2-4de288e9c71c9b08d183bd44f87b17f6a6793134.zip
Moved from dev-python/menumaker to x11-misc/menumaker.
Diffstat (limited to 'x11-misc/menumaker/menumaker-0.17.ebuild')
-rw-r--r--x11-misc/menumaker/menumaker-0.17.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/menumaker/menumaker-0.17.ebuild b/x11-misc/menumaker/menumaker-0.17.ebuild
new file mode 100644
index 000000000000..42ded3fd1a01
--- /dev/null
+++ b/x11-misc/menumaker/menumaker-0.17.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/menumaker/menumaker-0.17.ebuild,v 1.1 2005/06/14 01:29:48 smithj Exp $
+
+inherit distutils
+
+MY_P=${P/menumaker/MenuMaker}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Utility that scans through the system and generates a menu of installed programs"
+HOMEPAGE="http://menumaker.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ~ppc amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.1"
+
+PYTHON_MODNAME="MenuMaker Prophet"
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install() {
+ distutils_python_version
+ dodir /usr/lib/python${PYVER}/site-packages
+ cp -r MenuMaker Prophet ${D}/usr/lib/python${PYVER}/site-packages
+ dobin mmaker mmaker-launch
+ dodoc CHANGES COPYING README
+}
+