summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-22 17:00:28 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-22 17:00:28 +0000
commit3c59ed4b848ebdf2b2793949585076aaa9a58923 (patch)
tree4f39669c6f1bf24e7681ee6824ecc6c17b626cb6 /x11-misc/lineakd
parentAdd ~sparc (diff)
downloadgentoo-2-3c59ed4b848ebdf2b2793949585076aaa9a58923.tar.gz
gentoo-2-3c59ed4b848ebdf2b2793949585076aaa9a58923.tar.bz2
gentoo-2-3c59ed4b848ebdf2b2793949585076aaa9a58923.zip
Fix building with GCC 4.3, thanks to Peter Alfredsen wrt #218784.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'x11-misc/lineakd')
-rw-r--r--x11-misc/lineakd/ChangeLog6
-rw-r--r--x11-misc/lineakd/files/lineakd-0.9.0-gcc43.patch43
-rw-r--r--x11-misc/lineakd/lineakd-0.9.0-r1.ebuild14
3 files changed, 58 insertions, 5 deletions
diff --git a/x11-misc/lineakd/ChangeLog b/x11-misc/lineakd/ChangeLog
index 447e07c7de0f..2df7c99f253a 100644
--- a/x11-misc/lineakd/ChangeLog
+++ b/x11-misc/lineakd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/lineakd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/ChangeLog,v 1.50 2008/01/07 10:51:50 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/ChangeLog,v 1.51 2008/04/22 17:00:28 drac Exp $
+
+ 22 Apr 2008; Samuli Suominen <drac@gentoo.org>
+ +files/lineakd-0.9.0-gcc43.patch, lineakd-0.9.0-r1.ebuild:
+ Fix building with GCC 4.3, thanks to Peter Alfredsen wrt #218784.
07 Jan 2008; Krzysiek Pawlik <nelchael@gentoo.org>
lineakd-0.9.0_pre1.ebuild, lineakd-0.9.0-r1.ebuild:
diff --git a/x11-misc/lineakd/files/lineakd-0.9.0-gcc43.patch b/x11-misc/lineakd/files/lineakd-0.9.0-gcc43.patch
new file mode 100644
index 000000000000..95e1c7cde8a3
--- /dev/null
+++ b/x11-misc/lineakd/files/lineakd-0.9.0-gcc43.patch
@@ -0,0 +1,43 @@
+
+--- lineakd-0.9.orig/lineak/xmgr.cpp
++++ lineakd-0.9/lineak/xmgr.cpp
+@@ -21,6 +21,8 @@
+ #include <lineak/lbutton.h>
+
+ extern "C" {
++ #include <stdlib.h>
++ #include <string.h>
+ #include <signal.h>
+ #include <X11/Xlib.h>
+ #include <X11/keysym.h>
+--- lineakd-0.9.orig/lineak/defloader.h
++++ lineakd-0.9/lineak/defloader.h
+@@ -23,6 +23,7 @@
+ # endif
+
+ # include <lineak/loader.h>
++# include <cstdlib>
+ # include <map>
+
+ class LDef;
+--- lineakd-0.9.orig/lineak/pluginmanager.cpp
++++ lineakd-0.9/lineak/pluginmanager.cpp
+@@ -34,6 +34,7 @@
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <dlfcn.h>
++#include <string.h>
+ }
+
+ using namespace lineak_core_functions;
+--- lineakd-0.9.orig/lineak/cdromctrl.cpp
++++ lineakd-0.9/lineak/cdromctrl.cpp
+@@ -51,6 +51,7 @@
+
+ #include <stdio.h>
+ #include <errno.h>
++#include <string.h>
+ #include <unistd.h>
+
+ }
+
diff --git a/x11-misc/lineakd/lineakd-0.9.0-r1.ebuild b/x11-misc/lineakd/lineakd-0.9.0-r1.ebuild
index a8270c3af167..ee818f198c78 100644
--- a/x11-misc/lineakd/lineakd-0.9.0-r1.ebuild
+++ b/x11-misc/lineakd/lineakd-0.9.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/lineakd-0.9.0-r1.ebuild,v 1.7 2008/01/07 10:51:50 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/lineakd-0.9.0-r1.ebuild,v 1.8 2008/04/22 17:00:28 drac Exp $
-inherit multilib
+inherit eutils multilib
MY_P=${P/.0/}
@@ -27,14 +27,20 @@ DEPEND="${RDEPEND}
x11-proto/xproto
x11-libs/libXtst"
-S="${WORKDIR}"/${MY_P}
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
src_compile() {
econf $(use_enable debug) --with-x
emake || die "emake failed."
}
-src_install () {
+src_install() {
sed -i -e 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' lineakd/Makefile
dodir /usr/share/man/man8