summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-03-26 00:23:20 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-03-26 00:23:20 +0000
commit02a554173378b0ca621b39027f6ef47b34723582 (patch)
tree03bbf420281468d1904a4a5ac790c0a11b2d5d2a /x11-misc/lineakd/lineakd-0.9.0_pre1.ebuild
parentversion bump (diff)
downloadgentoo-2-02a554173378b0ca621b39027f6ef47b34723582.tar.gz
gentoo-2-02a554173378b0ca621b39027f6ef47b34723582.tar.bz2
gentoo-2-02a554173378b0ca621b39027f6ef47b34723582.zip
version bump
(Portage version: 2.1_pre6-r6)
Diffstat (limited to 'x11-misc/lineakd/lineakd-0.9.0_pre1.ebuild')
-rw-r--r--x11-misc/lineakd/lineakd-0.9.0_pre1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/lineakd/lineakd-0.9.0_pre1.ebuild b/x11-misc/lineakd/lineakd-0.9.0_pre1.ebuild
new file mode 100644
index 000000000000..fdc081d7e295
--- /dev/null
+++ b/x11-misc/lineakd/lineakd-0.9.0_pre1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lineakd/lineakd-0.9.0_pre1.ebuild,v 1.1 2006/03/26 00:23:20 genstef Exp $
+
+inherit eutils
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Linux support for Easy Access and Internet Keyboards features X11 support"
+HOMEPAGE="http://lineak.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="|| ( (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( (
+ x11-libs/libxkbfile
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/xproto )
+ virtual/x11 )"
+
+src_compile() {
+ econf --with-x || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ sed -i 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' lineakd/Makefile
+
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS README TODO
+ keepdir /usr/lib/lineakd/plugins
+
+ insinto /etc/lineak
+ doins lineakd.conf.example
+ doins lineakd.conf.kde.example
+}