summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-11-01 09:22:03 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-11-01 09:22:03 +0000
commit77da67314fda39caa7d4475fc05d54b9a1150951 (patch)
treec0e806f1a3e6e68f2206a22d4790b12d1bfff7af /x11-misc/idesk/idesk-0.3.4.ebuild
parentinitial import (diff)
downloadgentoo-2-77da67314fda39caa7d4475fc05d54b9a1150951.tar.gz
gentoo-2-77da67314fda39caa7d4475fc05d54b9a1150951.tar.bz2
gentoo-2-77da67314fda39caa7d4475fc05d54b9a1150951.zip
version bump
Diffstat (limited to 'x11-misc/idesk/idesk-0.3.4.ebuild')
-rw-r--r--x11-misc/idesk/idesk-0.3.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/idesk/idesk-0.3.4.ebuild b/x11-misc/idesk/idesk-0.3.4.ebuild
new file mode 100644
index 000000000000..68fef8eb2f20
--- /dev/null
+++ b/x11-misc/idesk/idesk-0.3.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/idesk/idesk-0.3.4.ebuild,v 1.1 2002/11/01 09:22:03 bcowan Exp $
+DESCRIPTION="Utility to place icons on the root window"
+
+HOMEPAGE="http://linuxhelp.hn.org/idesk.php"
+SRC_URI="http://linuxhelp.hn.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">media-libs/imlib-1.9.14
+ virtual/x11"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ #Allow for more robust CXXFLAGS
+ mv Makefile Makefile.orig
+ sed -e "s/-g -O2/${CXXFLAGS}/" Makefile.orig > Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe idesk
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "NOTE: Please refer to ${HOMEPAGE}"
+ einfo "NOTE: For info on configuring ${PN}"
+ einfo
+} \ No newline at end of file