summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-21 16:03:37 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-21 16:03:37 +0000
commit3f9ce99a0ee1b620328d55e364a40392650d8186 (patch)
treeace4e394d5523b384f8a82479f6245bdf6a22bcb /x11-misc/gromit
parentFix up metadata.xml. If there's no maintainer for the package, the metadata a... (diff)
downloadgentoo-2-3f9ce99a0ee1b620328d55e364a40392650d8186.tar.gz
gentoo-2-3f9ce99a0ee1b620328d55e364a40392650d8186.tar.bz2
gentoo-2-3f9ce99a0ee1b620328d55e364a40392650d8186.zip
Move pkgconfig from RDEPEND to DEPEND. Use toolchain-funcs for CC.
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'x11-misc/gromit')
-rw-r--r--x11-misc/gromit/ChangeLog7
-rw-r--r--x11-misc/gromit/gromit-20041213.ebuild26
2 files changed, 17 insertions, 16 deletions
diff --git a/x11-misc/gromit/ChangeLog b/x11-misc/gromit/ChangeLog
index 1312494eeda3..ee3c695a0099 100644
--- a/x11-misc/gromit/ChangeLog
+++ b/x11-misc/gromit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/gromit
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/gromit/ChangeLog,v 1.11 2007/05/11 16:17:56 bangert Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gromit/ChangeLog,v 1.12 2008/04/21 16:03:37 drac Exp $
+
+ 21 Apr 2008; Samuli Suominen <drac@gentoo.org> gromit-20041213.ebuild:
+ Move pkgconfig from RDEPEND to DEPEND. Use toolchain-funcs for CC.
11 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
fix herd
diff --git a/x11-misc/gromit/gromit-20041213.ebuild b/x11-misc/gromit/gromit-20041213.ebuild
index 8e8e4cafe47c..946b30fb96cd 100644
--- a/x11-misc/gromit/gromit-20041213.ebuild
+++ b/x11-misc/gromit/gromit-20041213.ebuild
@@ -1,32 +1,30 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/gromit/gromit-20041213.ebuild,v 1.5 2006/12/18 06:41:15 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/gromit/gromit-20041213.ebuild,v 1.6 2008/04/21 16:03:37 drac Exp $
-DESCRIPTION="GRaphics Over MIscellaneous Things, a presentation helper"
+inherit toolchain-funcs
-HOMEPAGE="http://www.home.unix-ag.org/simon/gromit/"
+DESCRIPTION="GRaphics Over MIscellaneous Things, a presentation helper"
+HOMEPAGE="http://www.home.unix-ag.org/simon/gromit"
SRC_URI="http://www.home.unix-ag.org/simon/gromit/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="ppc x86"
-
+KEYWORDS="~amd64 ppc x86"
IUSE=""
-DEPEND=">=x11-libs/gtk+-2.0
+RDEPEND=">=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_unpack() {
unpack ${A}
-
- sed -i "s:-Wall:-Wall ${CFLAGS}:" ${S}/Makefile
+ sed -e "s:-Wall:-Wall ${CFLAGS}:" \
+ -e "s:gcc:$(tc-getCC):g" -i "${S}"/Makefile
}
src_install() {
- exeinto /usr/bin
- doexe gromit
-
- newdoc gromitrc gromitrc.example
-
+ dobin ${PN}
+ newdoc ${PN}rc ${PN}rc.example
dodoc AUTHORS ChangeLog README
}