summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-02-05 09:38:29 +0000
committerJeroen Roovers <jer@gentoo.org>2015-02-05 09:38:29 +0000
commit26554c655c5b9b944a7128bfbe277cc9283da9ac (patch)
treecfb2702982722d07012f41b743fb3d7303fbb002 /x11-misc/fraqtive
parentVersion bump. (diff)
downloadgentoo-2-26554c655c5b9b944a7128bfbe277cc9283da9ac.tar.gz
gentoo-2-26554c655c5b9b944a7128bfbe277cc9283da9ac.tar.bz2
gentoo-2-26554c655c5b9b944a7128bfbe277cc9283da9ac.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/fraqtive')
-rw-r--r--x11-misc/fraqtive/ChangeLog8
-rw-r--r--x11-misc/fraqtive/files/fraqtive-0.4.5-qt-4.8.patch26
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.8.ebuild (renamed from x11-misc/fraqtive/fraqtive-0.4.6.ebuild)38
3 files changed, 36 insertions, 36 deletions
diff --git a/x11-misc/fraqtive/ChangeLog b/x11-misc/fraqtive/ChangeLog
index bfda649b7cd1..6fdd4d07bf57 100644
--- a/x11-misc/fraqtive/ChangeLog
+++ b/x11-misc/fraqtive/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/fraqtive
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/ChangeLog,v 1.16 2015/01/28 22:22:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/ChangeLog,v 1.17 2015/02/05 09:38:29 jer Exp $
+
+*fraqtive-0.4.8 (05 Feb 2015)
+
+ 05 Feb 2015; Jeroen Roovers <jer@gentoo.org> -fraqtive-0.4.6.ebuild,
+ +fraqtive-0.4.8.ebuild, -files/fraqtive-0.4.5-qt-4.8.patch:
+ Version bump.
28 Jan 2015; Michał Górny <mgorny@gentoo.org> fraqtive-0.4.6.ebuild,
fraqtive-0.4.7.ebuild:
diff --git a/x11-misc/fraqtive/files/fraqtive-0.4.5-qt-4.8.patch b/x11-misc/fraqtive/files/fraqtive-0.4.5-qt-4.8.patch
deleted file mode 100644
index a60c4d6f927a..000000000000
--- a/x11-misc/fraqtive/files/fraqtive-0.4.5-qt-4.8.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Description: Fix FTBFS with Qt 4.8. Include and link against GLU.
-Author: Felix Geyer <debfx-pkg@fobos.de>
-
---- fraqtive-0.4.5.orig/src/src.pro
-+++ fraqtive-0.4.5/src/src.pro
-@@ -154,6 +154,10 @@ win32 {
- LIBS += -lshell32
- }
-
-+unix {
-+ LIBS += -lGLU
-+}
-+
- MOC_DIR = ../tmp
- RCC_DIR = ../tmp
- UI_DIR = ../tmp
---- fraqtive-0.4.5.orig/src/meshview.cpp
-+++ fraqtive-0.4.5/src/meshview.cpp
-@@ -19,6 +19,7 @@
- #include <QMouseEvent>
- #include <QWheelEvent>
- #include <QKeyEvent>
-+#include <GL/glu.h>
-
- #include "fractalpresenter.h"
- #include "datafunctions.h"
diff --git a/x11-misc/fraqtive/fraqtive-0.4.6.ebuild b/x11-misc/fraqtive/fraqtive-0.4.8.ebuild
index 7d920f8bc96f..cb4a4fc1e9e7 100644
--- a/x11-misc/fraqtive/fraqtive-0.4.6.ebuild
+++ b/x11-misc/fraqtive/fraqtive-0.4.8.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/fraqtive-0.4.6.ebuild,v 1.4 2015/01/28 22:22:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/fraqtive-0.4.8.ebuild,v 1.1 2015/02/05 09:38:29 jer Exp $
EAPI=5
-inherit eutils gnome2-utils qt4-r2
+inherit eutils gnome2-utils qmake-utils toolchain-funcs
DESCRIPTION="an open source, multi-platform generator of the Mandelbrot family fractals"
HOMEPAGE="http://fraqtive.mimec.org/"
@@ -12,17 +12,29 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="cpu_flags_x86_sse2"
+IUSE="qt5 cpu_flags_x86_sse2"
-DEPEND="
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtopengl:4
+RDEPEND="
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ )
virtual/glu
"
-RDEPEND="${DEPEND}"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
src_configure() {
+ tc-export PKG_CONFIG
+ sed -i -e "s|-lGLU|$( ${PKG_CONFIG} --libs glu )|g" src/src.pro || die
local conf="release"
if use cpu_flags_x86_sse2; then
@@ -36,7 +48,15 @@ src_configure() {
# Don't strip wrt #252096
echo "QMAKE_STRIP =" >> "${S}"/config.pri
- qt4-r2_src_configure
+ if use qt5; then
+ eqmake5
+ else
+ eqmake4
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
}
pkg_preinst() {