summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2009-02-02 16:59:38 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2009-02-02 16:59:38 +0000
commit43846bcd8ab83e18c0eda1550afed1fa0486d3a1 (patch)
tree67d282c055bdfa0dee73a28693ca8ac2b1a9bd65 /x11-misc/fraqtive/fraqtive-0.4.4.ebuild
parentppc stable #257292 (diff)
downloadgentoo-2-43846bcd8ab83e18c0eda1550afed1fa0486d3a1.tar.gz
gentoo-2-43846bcd8ab83e18c0eda1550afed1fa0486d3a1.tar.bz2
gentoo-2-43846bcd8ab83e18c0eda1550afed1fa0486d3a1.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/fraqtive/fraqtive-0.4.4.ebuild')
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/fraqtive/fraqtive-0.4.4.ebuild b/x11-misc/fraqtive/fraqtive-0.4.4.ebuild
new file mode 100644
index 000000000000..cf9c39545361
--- /dev/null
+++ b/x11-misc/fraqtive/fraqtive-0.4.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fraqtive/fraqtive-0.4.4.ebuild,v 1.1 2009/02/02 16:59:38 drizzt Exp $
+
+EAPI=1
+
+inherit qt4
+
+DESCRIPTION="Fraqtive is a KDE-based program for interactively drawing Mandelbrot and Julia fractals"
+HOMEPAGE="http://fraqtive.mimec.org/"
+SRC_URI="mirror://sourceforge/fraqtive/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sse2"
+
+RDEPEND="|| ( ( x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-opengl )
+ <x11-libs/qt-4.4:4 )"
+DEPEND="${RDEPEND}"
+
+QT4_BUILT_WITH_USE_CHECK="opengl"
+
+src_unpack() {
+ local conf="release"
+
+ if use sse2; then
+ conf="$conf sse2"
+ else
+ conf="$conf no-sse2"
+ fi
+
+ unpack ${A}
+
+ echo "CONFIG += $conf" > "${S}"/config.pri
+ echo "PREFIX = /usr" >> "${S}"/config.pri
+}
+
+src_compile() {
+ eqmake4
+ emake || die "make failed"
+}
+
+src_install() {
+ make install INSTALL_ROOT="${D}" || die "install failed"
+}