summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-06 17:59:10 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-01-06 17:59:10 +0000
commit140637b4e66fcd3e6a8461e415cd12d2fcf5e76a (patch)
tree581d86c189eece98478963064b8b5b8e9309dda3 /x11-misc/colord
parentVersion bump. (diff)
downloadgentoo-2-140637b4e66fcd3e6a8461e415cd12d2fcf5e76a.tar.gz
gentoo-2-140637b4e66fcd3e6a8461e415cd12d2fcf5e76a.tar.bz2
gentoo-2-140637b4e66fcd3e6a8461e415cd12d2fcf5e76a.zip
Disable systemd in stable ebuild; add 0.1.26-r1 for systemd support. Thanks to Markus Meier for pointing out the problem.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'x11-misc/colord')
-rw-r--r--x11-misc/colord/ChangeLog9
-rw-r--r--x11-misc/colord/colord-0.1.26-r1.ebuild98
-rw-r--r--x11-misc/colord/colord-0.1.26.ebuild9
3 files changed, 111 insertions, 5 deletions
diff --git a/x11-misc/colord/ChangeLog b/x11-misc/colord/ChangeLog
index 31e9f23bcb7f..63d5f9a45f86 100644
--- a/x11-misc/colord/ChangeLog
+++ b/x11-misc/colord/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/colord
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/ChangeLog,v 1.49 2013/01/06 11:22:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/ChangeLog,v 1.50 2013/01/06 17:59:10 tetromino Exp $
+
+*colord-0.1.26-r1 (06 Jan 2013)
+
+ 06 Jan 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ colord-0.1.26.ebuild, +colord-0.1.26-r1.ebuild:
+ Disable systemd in stable ebuild; add 0.1.26-r1 for systemd support. Thanks
+ to Markus Meier for pointing out the problem.
06 Jan 2013; Agostino Sarubbo <ago@gentoo.org> colord-0.1.26.ebuild:
Add ~sparc, wrt bug #449220
diff --git a/x11-misc/colord/colord-0.1.26-r1.ebuild b/x11-misc/colord/colord-0.1.26-r1.ebuild
new file mode 100644
index 000000000000..df517bb95342
--- /dev/null
+++ b/x11-misc/colord/colord-0.1.26-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/colord-0.1.26-r1.ebuild,v 1.1 2013/01/06 17:59:10 tetromino Exp $
+
+EAPI="5"
+VALA_MIN_API_VERSION="0.18"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools bash-completion-r1 eutils user systemd base udev vala
+
+DESCRIPTION="System service to accurately color manage input and output devices"
+HOMEPAGE="http://www.freedesktop.org/software/colord/"
+SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/1" # subslot = libcolord soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples +gusb +introspection systemd +udev vala"
+REQUIRED_USE="vala? ( introspection )"
+
+COMMON_DEPEND="
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.28.0:2
+ >=media-libs/lcms-2.2:2=
+ >=sys-auth/polkit-0.103
+ gusb? ( >=dev-libs/libgusb-0.1.1 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
+ systemd? ( >=sys-apps/systemd-44 )
+ udev? ( virtual/udev:=[gudev] )"
+RDEPEND="${COMMON_DEPEND}
+ media-gfx/shared-color-profiles"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.9 )
+ vala? ( $(vala_depend) )"
+
+# FIXME: needs pre-installed dbus service files
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup colord
+ enewuser colord -1 -1 /var/lib/colord colord
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+
+ epatch "${FILESDIR}/${PN}-0.1.26-fix-automagic-systemd.patch"
+ eautoreconf
+}
+
+src_configure() {
+ # Reverse tools require gusb
+ econf \
+ --disable-examples \
+ --disable-static \
+ --enable-polkit \
+ --disable-volume-search \
+ --with-daemon-user=colord \
+ --localstatedir="${EPREFIX}"/var \
+ $(use_enable doc gtk-doc) \
+ $(use_enable gusb) \
+ $(use_enable gusb reverse) \
+ $(use_enable introspection) \
+ $(use_enable systemd libsystemd-login) \
+ $(use_enable udev gudev) \
+ --with-udevrulesdir="$(udev_get_udevdir)"/rules.d \
+ $(use_enable vala) \
+ "$(systemd_with_unitdir)"
+
+ # parallel make fails in doc/api
+ use doc && MAKEOPTS="${MAKEOPTS} -j1"
+}
+
+src_install() {
+ DOCS=(AUTHORS ChangeLog MAINTAINERS NEWS README TODO)
+ default
+
+ newbashcomp client/colormgr-completion.bash colormgr
+ rm -vr "${ED}etc/bash_completion.d"
+
+ # Ensure config and profile directories exist and /var/lib/colord/*
+ # is writable by colord user
+ keepdir /var/lib/color{,d}/icc
+ fowners colord:colord /var/lib/colord{,/icc}
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+
+ prune_libtool_files --modules
+}
diff --git a/x11-misc/colord/colord-0.1.26.ebuild b/x11-misc/colord/colord-0.1.26.ebuild
index ad378f9ce1d3..1c031eafae5c 100644
--- a/x11-misc/colord/colord-0.1.26.ebuild
+++ b/x11-misc/colord/colord-0.1.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/colord-0.1.26.ebuild,v 1.7 2013/01/06 11:22:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/colord/colord-0.1.26.ebuild,v 1.8 2013/01/06 17:59:10 tetromino Exp $
EAPI="5"
VALA_MIN_API_VERSION="0.18"
@@ -15,7 +15,7 @@ SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
LICENSE="GPL-2+"
SLOT="0/1" # subslot = libcolord soname version
KEYWORDS="~alpha amd64 ~arm ia64 ~mips ppc ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="doc examples +gusb +introspection systemd +udev vala"
+IUSE="doc examples +gusb +introspection +udev vala" #systemd
REQUIRED_USE="vala? ( introspection )"
COMMON_DEPEND="
@@ -25,8 +25,8 @@ COMMON_DEPEND="
>=sys-auth/polkit-0.103
gusb? ( >=dev-libs/libgusb-0.1.1 )
introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
- systemd? ( >=sys-apps/systemd-44 )
udev? ( virtual/udev:=[gudev] )"
+# systemd? ( >=sys-apps/systemd-44 )
RDEPEND="${COMMON_DEPEND}
media-gfx/shared-color-profiles"
DEPEND="${COMMON_DEPEND}
@@ -67,11 +67,12 @@ src_configure() {
$(use_enable gusb) \
$(use_enable gusb reverse) \
$(use_enable introspection) \
- $(use_enable systemd libsystemd-login) \
+ --disable-libsystemd-login \
$(use_enable udev gudev) \
--with-udevrulesdir="$(udev_get_udevdir)"/rules.d \
$(use_enable vala) \
"$(systemd_with_unitdir)"
+ # $(use_enable systemd libsystemd-login) \
# parallel make fails in doc/api
use doc && MAKEOPTS="${MAKEOPTS} -j1"