summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Bouyer <stubear@gentoo.org>2002-08-21 16:31:50 +0000
committerStuart Bouyer <stubear@gentoo.org>2002-08-21 16:31:50 +0000
commit3d53a568841c6ba467c15b15e52a9bd733f42122 (patch)
tree481673dfa73450bd565f3f4f04b13ed0eff9028e /x11-misc/arphicfonts
parenttesting arphicfonts (diff)
downloadgentoo-2-3d53a568841c6ba467c15b15e52a9bd733f42122.tar.gz
gentoo-2-3d53a568841c6ba467c15b15e52a9bd733f42122.tar.bz2
gentoo-2-3d53a568841c6ba467c15b15e52a9bd733f42122.zip
moved fonts to their own dir and added complete fonts.scale
Diffstat (limited to 'x11-misc/arphicfonts')
-rw-r--r--x11-misc/arphicfonts/ChangeLog9
-rw-r--r--x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild63
-rw-r--r--x11-misc/arphicfonts/files/CN-fonts.scale5
-rw-r--r--x11-misc/arphicfonts/files/TW-fonts.scale11
-rw-r--r--x11-misc/arphicfonts/files/digest-arphicfonts-0.1-r14
5 files changed, 91 insertions, 1 deletions
diff --git a/x11-misc/arphicfonts/ChangeLog b/x11-misc/arphicfonts/ChangeLog
index fcc3eca604b8..ae2ec3eb73af 100644
--- a/x11-misc/arphicfonts/ChangeLog
+++ b/x11-misc/arphicfonts/ChangeLog
@@ -1,8 +1,15 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/arphicfonts/ChangeLog,v 1.1 2002/06/26 17:49:08 stubear Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/arphicfonts/ChangeLog,v 1.2 2002/08/21 16:31:50 stubear Exp $
*arphicfonts-0.1 (27 June 2002)
+ 22 Aug 2002; Stuart Bouyer <stubear@gentoo.org> arphicfonts-0.1-r1.ebuild,
+ files/CN-fonts.scale, files/TW-fonts.scale:
+
+ Marko Daniel <mdaniel@soton.ac.uk> has updated the ebuild to install the
+ fonts in their own directory and fixed a bug where the font encoding info
+ wasn't being correctly produced for big5 and gb encodings. Closes bug 6281.
+
27 June 2002; Stuart Bouyer <stubear@gentoo.org> arphicfonts-0.1.ebuild:
First ebuild added
diff --git a/x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild b/x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild
new file mode 100644
index 000000000000..d49eb8f9980a
--- /dev/null
+++ b/x11-misc/arphicfonts/arphicfonts-0.1-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyrigth 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+#/space/gentoo/cvsroot/gentoo-x86/x11-misc/arphicfonts/arphicfonts.ebuild
+
+DESCRIPTION="Arphic Fonts"
+SRC_URI="ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/gkai00mp.ttf.gz
+ ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/bkai00mp.ttf.gz
+ ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/bsmi00lp.ttf.gz
+ ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/gbsn00lp.ttf.gz"
+HOMEPAGE="http://www.arphic.com.tw/"
+LICENSE="Arphic"
+SLOT="0"
+KEYWORDS="x86"
+S=${WORKDIR}
+
+DEPEND="virtual/x11
+ x11-misc/ttmkfdir"
+RDEPEND=${DEPEND}
+
+src_install() {
+ cd ${S}
+ insopts -m0644
+ insinto /usr/share/fonts/ttf/zh_TW
+ doins b*.ttf
+ newins ${FILESDIR}/TW-fonts.scale fonts.scale
+ insinto /usr/share/fonts/ttf/zh_CN
+ doins g*.ttf
+ newins ${FILESDIR}/CN-fonts.scale fonts.scale
+
+# These don't get downloaded because there is no simple way to
+# fetch them.. ie if I included the README in SRC_URI above, it would
+# get saved as /usr/portage/distfiles/README which doesn't seem like
+# a really good idea.
+# dodoc LICENSE README
+}
+
+pkg_postinst() {
+ echo ">>> Making big5 font dirs..."
+ cd /usr/share/fonts/ttf/zh_TW
+ echo ">>> Creating fonts.dir info"
+ mkfontdir -e /usr/X11R6/lib/X11/fonts/encodings/large \
+ -e /usr/X11R6/lib/X11/fonts/encodings
+ echo ">>> Making gb2312 font dirs..."
+ cd /usr/share/fonts/ttf/zh_CN
+ echo ">>> Creating fonts.dir info"
+ mkfontdir -e /usr/X11R6/lib/X11/fonts/encodings/large \
+ -e /usr/X11R6/lib/X11/fonts/encodings
+ echo ">>> Make sure X knows about these font directories!"
+ if ( `grep -e "^.*FontPath.*\"/usr/share/fonts/ttf/zh_TW\"" /etc/X11/XF86Config -q` ); then
+ echo "Font path for big5 fonts is listed in /etc/X11/XF86Config."
+ else
+ echo ">>> You must add /usr/share/fonts/ttf/zh_TW to your font path"
+ echo ">>> to be able to use your new Big5 fonts."
+ fi
+ if ( `grep -e "^.*[fF]ont[Pp]ath.*\"/usr/share/fonts/ttf/zh_CN\"" /etc/X11/XF86Config -q` ); then
+ echo "Font path for gb2312 fonts is listed in /etc/X11/XF86Config."
+ else
+ echo ">>> You must add /usr/share/fonts/ttf/zh_CN to your font path"
+ echo ">>> to be able to use your new gb2312 fonts."
+ fi
+
+ echo ">>> Restart font server for changes to take effect."
+}
diff --git a/x11-misc/arphicfonts/files/CN-fonts.scale b/x11-misc/arphicfonts/files/CN-fonts.scale
new file mode 100644
index 000000000000..f6dc9059b90b
--- /dev/null
+++ b/x11-misc/arphicfonts/files/CN-fonts.scale
@@ -0,0 +1,5 @@
+4
+gkai00mp.ttf -arphic-ar pl kaitim gb-medium-r-normal--0-0-0-0-p-0-iso8859-1
+gkai00mp.ttf -arphic-ar pl kaitim gb-medium-r-normal--0-0-0-0-p-0-gb2312.1980-0
+gbsn00lp.ttf -arphic-ar pl sungtil gb-medium-r-normal--0-0-0-0-p-0-iso8859-1
+gbsn00lp.ttf -arphic-ar pl sungtil gb-medium-r-normal--0-0-0-0-p-0-gb2312.1980-0
diff --git a/x11-misc/arphicfonts/files/TW-fonts.scale b/x11-misc/arphicfonts/files/TW-fonts.scale
new file mode 100644
index 000000000000..5131770d2957
--- /dev/null
+++ b/x11-misc/arphicfonts/files/TW-fonts.scale
@@ -0,0 +1,11 @@
+10
+bkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM Big5-medium-r-normal--0-0-0-0-c-0-ascii-0
+bkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM Big5-medium-r-normal--0-0-0-0-c-0-big5-0
+bkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM Big5-medium-r-normal--0-0-0-0-c-0-big5.cp950-0
+bkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM Big5-medium-r-normal--0-0-0-0-c-0-big5.eten-0
+bkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM Big5-medium-r-normal--0-0-0-0-c-0-iso10646-1
+bsmi00lp.ttf -Arphic Technology Co.-AR PL Mingti2L Big5-medium-r-normal--0-0-0-0-c-0-ascii-0
+bsmi00lp.ttf -Arphic Technology Co.-AR PL Mingti2L Big5-medium-r-normal--0-0-0-0-c-0-big5-0
+bsmi00lp.ttf -Arphic Technology Co.-AR PL Mingti2L Big5-medium-r-normal--0-0-0-0-c-0-big5.cp950-0
+bsmi00lp.ttf -Arphic Technology Co.-AR PL Mingti2L Big5-medium-r-normal--0-0-0-0-c-0-big5.eten-0
+bsmi00lp.ttf -Arphic Technology Co.-AR PL Mingti2L Big5-medium-r-normal--0-0-0-0-c-0-iso10646-1
diff --git a/x11-misc/arphicfonts/files/digest-arphicfonts-0.1-r1 b/x11-misc/arphicfonts/files/digest-arphicfonts-0.1-r1
new file mode 100644
index 000000000000..8cb6db87971d
--- /dev/null
+++ b/x11-misc/arphicfonts/files/digest-arphicfonts-0.1-r1
@@ -0,0 +1,4 @@
+MD5 5ee11417a8b42d08a33421dd6c64bed2 gkai00mp.ttf.gz 2698942
+MD5 9abc1efeaf08df5554629b10eb79b1b2 bkai00mp.ttf.gz 6013768
+MD5 42b13b73c5572d886824ee249d1ad500 bsmi00lp.ttf.gz 5653466
+MD5 757ca4959ed2325d49a64730766140ee gbsn00lp.ttf.gz 2345803