summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-16 20:41:29 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-16 20:41:29 +0000
commit33c33d80b69243e7e2b7834ac93064d8a7813102 (patch)
tree770f3a1fdf7b6fb1a19aba10b1a0084b7a0f4da2 /x11-misc/alacarte
parentVersion bump. Memory leaks & bug fixes. (diff)
downloadgentoo-2-33c33d80b69243e7e2b7834ac93064d8a7813102.tar.gz
gentoo-2-33c33d80b69243e7e2b7834ac93064d8a7813102.tar.bz2
gentoo-2-33c33d80b69243e7e2b7834ac93064d8a7813102.zip
Version bump. Translation updates and make it build against python 2.7.
(Portage version: 2.2_rc78/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/alacarte')
-rw-r--r--x11-misc/alacarte/ChangeLog8
-rw-r--r--x11-misc/alacarte/alacarte-0.13.2.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/x11-misc/alacarte/ChangeLog b/x11-misc/alacarte/ChangeLog
index 10c4eaf5d479..c185a2d24fec 100644
--- a/x11-misc/alacarte/ChangeLog
+++ b/x11-misc/alacarte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/alacarte
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/ChangeLog,v 1.99 2010/09/11 18:54:45 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/ChangeLog,v 1.100 2010/09/16 20:41:29 eva Exp $
+
+*alacarte-0.13.2 (16 Sep 2010)
+
+ 16 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +alacarte-0.13.2.ebuild:
+ Version bump. Translation updates and make it build against python 2.7.
11 Sep 2010; Joseph Jezak <josejx@gentoo.org> alacarte-0.12.4.ebuild:
Marked ppc for bug #324077.
diff --git a/x11-misc/alacarte/alacarte-0.13.2.ebuild b/x11-misc/alacarte/alacarte-0.13.2.ebuild
new file mode 100644
index 000000000000..237c418068e9
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-0.13.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/alacarte/alacarte-0.13.2.ebuild,v 1.1 2010/09/16 20:41:29 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 python
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="http://live.gnome.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+SLOT=0
+
+common_depends=">=dev-lang/python-2.4
+ >=dev-python/pygobject-2.15.1
+ >=dev-python/pygtk-2.13
+ >=gnome-base/gnome-menus-2.27.92[python]"
+
+RDEPEND="${common_depends}
+ >=gnome-base/gnome-panel-2.16"
+
+DEPEND="${common_depends}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ >=dev-util/pkgconfig-0.19"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+ python_mod_optimize $(python_get_sitedir)/Alacarte
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/Alacarte
+}