summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-01-20 20:23:54 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-01-20 20:23:54 +0000
commitc6d905e182f965a3cc606c2db7eb5decbfbe028f (patch)
tree923a537115bcf1292365644d8ea92f628a679ec6 /x11-libs
parentFixed bug #122038, made this compile with jdks >=1.5, cleaned the ebuild and ... (diff)
downloadgentoo-2-c6d905e182f965a3cc606c2db7eb5decbfbe028f.tar.gz
gentoo-2-c6d905e182f965a3cc606c2db7eb5decbfbe028f.tar.bz2
gentoo-2-c6d905e182f965a3cc606c2db7eb5decbfbe028f.zip
new snapshot rev bump
(Portage version: 2.1.2-r1)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/ChangeLog7
-rw-r--r--x11-libs/cairo/cairo-1.3.12.ebuild67
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.3.123
3 files changed, 76 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 4e25cddaf292..d3d0ecd2e9c4 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.98 2007/01/08 01:29:36 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.99 2007/01/20 20:23:54 cardoe Exp $
+
+*cairo-1.3.12 (20 Jan 2007)
+
+ 20 Jan 2007; Doug Goldstein <cardoe@gentoo.org> +cairo-1.3.12.ebuild:
+ new snapshot rev bump
07 Jan 2007; Doug Goldstein <cardoe@gentoo.org> cairo-1.2.6.ebuild,
cairo-1.3.10.ebuild:
diff --git a/x11-libs/cairo/cairo-1.3.12.ebuild b/x11-libs/cairo/cairo-1.3.12.ebuild
new file mode 100644
index 000000000000..bb31d5825ac6
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.3.12.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.3.12.ebuild,v 1.1 2007/01/20 20:23:54 cardoe Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/snapshots/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug directfb doc glitz svg X xcb"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1.4
+ media-libs/libpng
+ X? (
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-libs/libX11
+ virtual/xft
+ xcb? ( x11-libs/libxcb
+ x11-libs/xcb-util )
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ glitz? ( >=media-libs/glitz-0.5.1 )
+ svg? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ X? ( x11-proto/renderproto
+ xcb? ( x11-proto/xcb-proto ) )
+ doc? (
+ >=dev-util/gtk-doc-1.3
+ ~app-text/docbook-xml-dtd-4.2
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need to run elibtoolize to ensure correct so versioning on FreeBSD
+ elibtoolize
+}
+
+src_compile() {
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
+ $(use_enable svg) $(use_enable glitz) \
+ $(use_enable debug test-surfaces) --enable-pdf --enable-png \
+ --enable-freetype --enable-ps $(use_enable xcb) \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/x11-libs/cairo/files/digest-cairo-1.3.12 b/x11-libs/cairo/files/digest-cairo-1.3.12
new file mode 100644
index 000000000000..cda44ca8d913
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.3.12
@@ -0,0 +1,3 @@
+MD5 b6ac81de3c47529d1f39390943728c3d cairo-1.3.12.tar.gz 2812615
+RMD160 2604af4bf3f98abdd586391dc5e43a3cb845ad16 cairo-1.3.12.tar.gz 2812615
+SHA256 7337cec2f20e4a350d39f87a86c7fe04ae62bae412a8f3e77d1d749389ae9127 cairo-1.3.12.tar.gz 2812615