summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-07-31 12:10:21 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-07-31 12:10:21 +0000
commitbd89e885f0f2753ab9ea671afc662f8a50d1fd94 (patch)
tree77847fe5e613ba755b381eaa5873af12e2b35c94 /x11-libs
parentnew local use flag for qt (diff)
downloadgentoo-2-bd89e885f0f2753ab9ea671afc662f8a50d1fd94.tar.gz
gentoo-2-bd89e885f0f2753ab9ea671afc662f8a50d1fd94.tar.bz2
gentoo-2-bd89e885f0f2753ab9ea671afc662f8a50d1fd94.zip
Add pch support for qt-4.2
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog5
-rw-r--r--x11-libs/qt/qt-4.2.0_pre1.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 88a90f98a115..0c0f7ab4fefd 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.334 2006/07/28 12:33:57 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.335 2006/07/31 12:10:21 caleb Exp $
+
+ 31 Jul 2006; Caleb Tennis <caleb@gentoo.org> qt-4.2.0_pre1.ebuild:
+ Add pch support for qt-4.2
28 Jul 2006; Caleb Tennis <caleb@gentoo.org> qt-4.1.4.ebuild,
qt-4.2.0_pre1.ebuild:
diff --git a/x11-libs/qt/qt-4.2.0_pre1.ebuild b/x11-libs/qt/qt-4.2.0_pre1.ebuild
index 31e08de91156..08aeb6185561 100644
--- a/x11-libs/qt/qt-4.2.0_pre1.ebuild
+++ b/x11-libs/qt/qt-4.2.0_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.2.0_pre1.ebuild,v 1.5 2006/07/28 12:33:57 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.2.0_pre1.ebuild,v 1.6 2006/07/31 12:10:21 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -15,7 +15,7 @@ LICENSE="|| ( QPL-1.0 GPL-2 )"
SLOT="4"
#KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
KEYWORDS="-*"
-IUSE="accessibility cups debug dbus doc examples firebird gif glib jpeg mng mysql nas nis odbc opengl png postgres sqlite xinerama zlib"
+IUSE="accessibility cups debug dbus doc examples firebird gif glib jpeg mng mysql nas nis odbc opengl pch png postgres sqlite xinerama zlib"
# need glib and dbus
@@ -143,6 +143,8 @@ src_compile() {
use dbus && myconf="${myconf} -qdbus" || myconf="${myconf} -no-qdbus"
use glib && myconf="${myconf} -glib" || myconf="${myconf} -no-glib"
+ use pch && myconf="${myconf} -pch"
+
myconf="${myconf} -tablet -xrender -xrandr -xkb -xshape -sm"
./configure -stl -verbose -largefile \