summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:13:57 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-03-05 23:13:57 +0000
commitb7cf872845471dd93d6ad2f49dbe93c8d40aaa5c (patch)
tree194c017c8cd18e03002d46787a6f345f18c2d4a2 /x11-libs
parentAdded Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled (diff)
downloadgentoo-2-b7cf872845471dd93d6ad2f49dbe93c8d40aaa5c.tar.gz
gentoo-2-b7cf872845471dd93d6ad2f49dbe93c8d40aaa5c.tar.bz2
gentoo-2-b7cf872845471dd93d6ad2f49dbe93c8d40aaa5c.zip
Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
`technical preview`, so this will appear as a downgrade if you installed that version. Thanks to David Leverton, Bo Andresen, Bernd Steinhauser & Arfrever Frehtes Taifersar Arahesis Fixes bugs: 206975, 212086, 172219, 212069, 206976 (Portage version: 2.1.4.4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-assistant/ChangeLog13
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.4.0_beta1.ebuild48
2 files changed, 59 insertions, 2 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 4ba490ecfbb5..f3a6fbde72de 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-libs/qt-assistant
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.1 2007/12/24 14:52:28 caleb Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.2 2008/03/05 23:13:57 ingmar Exp $
+
+*qt-assistant-4.4.0_beta1 (05 Mar 2008)
+
+ 05 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ +qt-assistant-4.4.0_beta1.ebuild:
+ Added Qt-4.4.0_beta, note that the RC1 is an accidentally mislabelled
+ `technical preview`, so this will appear as a downgrade if you installed
+ that version.
+ Fixes bug 212108, thanks to Markus Rothe.
*qt-assistant-4.4.0_rc1 (24 Dec 2007)
diff --git a/x11-libs/qt-assistant/qt-assistant-4.4.0_beta1.ebuild b/x11-libs/qt-assistant/qt-assistant-4.4.0_beta1.ebuild
new file mode 100644
index 000000000000..7f7f7741e4fc
--- /dev/null
+++ b/x11-libs/qt-assistant/qt-assistant-4.4.0_beta1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.4.0_beta1.ebuild,v 1.1 2008/03/05 23:13:57 ingmar Exp $
+
+inherit qt4-build
+
+DESCRIPTION="The assistant help module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="~x11-libs/qt-gui-${PV}
+ ~x11-libs/qt-sql-${PV}"
+RDEPEND="${DEPEND}"
+
+# Pixeltool isn't really assistant related, but it relies on
+# the assistant libraries.
+QT4_TARGET_DIRECTORIES="tools/assistant tools/pixeltool"
+
+pkg_setup() {
+ qt4-build_pkg_setup
+
+ if ! built_with_use x11-libs/qt-sql sqlite; then
+ die "You must first emerge x11-libs/qt-sql with the \"sqlite\" use flag in order to use qt-assistant"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-qdbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
+ -no-glib -no-opengl -no-qt3support"
+
+ qt4-build_src_compile
+}
+
+src_install() {
+ qt4-build_src_install
+ domenu "${FILESDIR}"/assistant.desktop
+ use doc && dohtml -r doc/html/*
+}