summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-12-05 03:27:45 +0000
committerBen de Groot <yngwin@gentoo.org>2012-12-05 03:27:45 +0000
commita72a2d22cc29b5221bbd838191a60224c6fcfcb2 (patch)
treef1bc3c20fac7b0ee2e60e71d571053a0b90de34f /x11-libs
parentQt 4.8.4 version bump (diff)
downloadgentoo-2-a72a2d22cc29b5221bbd838191a60224c6fcfcb2.tar.gz
gentoo-2-a72a2d22cc29b5221bbd838191a60224c6fcfcb2.tar.bz2
gentoo-2-a72a2d22cc29b5221bbd838191a60224c6fcfcb2.zip
Qt 4.8.4 version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-script/ChangeLog7
-rw-r--r--x11-libs/qt-script/qt-script-4.8.4.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index c09604217c0c..c75ed5b1ba96 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.134 2012/10/14 17:07:13 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.135 2012/12/05 03:27:45 yngwin Exp $
+
+*qt-script-4.8.4 (05 Dec 2012)
+
+ 05 Dec 2012; Ben de Groot <yngwin@gentoo.org> +qt-script-4.8.4.ebuild:
+ Qt 4.8.4 version bump
14 Oct 2012; Raúl Porcel <armin76@gentoo.org> qt-script-4.8.2.ebuild:
alpha/ia64/sparc stable wrt #424625
diff --git a/x11-libs/qt-script/qt-script-4.8.4.ebuild b/x11-libs/qt-script/qt-script-4.8.4.ebuild
new file mode 100644
index 000000000000..81c0f3b12aa8
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.8.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.8.4.ebuild,v 1.1 2012/12/05 03:27:45 yngwin Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+IUSE="iconv +jit"
+
+DEPEND="
+ ~x11-libs/qt-core-${PV}[aqua=,debug=]
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/script"
+
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ include/Qt
+ include/QtCore
+ include/QtScript
+ src/3rdparty/javascriptcore
+ src/corelib"
+
+ QCONFIG_ADD="script"
+ QCONFIG_DEFINE="QT_SCRIPT"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ $(qt_use iconv)
+ $(qt_use jit javascript-jit)
+ -no-xkb -no-fontconfig -no-xrender -no-xrandr -no-xfixes -no-xcursor -no-xinerama
+ -no-xshape -no-sm -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif
+ -no-libpng -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
+ -no-accessibility -no-fontconfig -no-glib -no-opengl -no-svg
+ -no-gtkstyle"
+
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+
+ # install private headers
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtScript/private
+ find "${S}"/src/script -type f -name "*_p.h" -exec doins {} +
+}