summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-10 14:08:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-10 14:08:21 +0000
commita495d90ed81e7289497d16eafc6c82c8bf11b9b9 (patch)
tree4abab3b5c640c8d04b640134ceb4f2612d32b94a /x11-libs
parentAdd fixed patch for 2.18, bug 238436, thanks to Andrew Savchenko <Bircoph@lis... (diff)
downloadgentoo-2-a495d90ed81e7289497d16eafc6c82c8bf11b9b9.tar.gz
gentoo-2-a495d90ed81e7289497d16eafc6c82c8bf11b9b9.tar.bz2
gentoo-2-a495d90ed81e7289497d16eafc6c82c8bf11b9b9.zip
* New version for GNOME 2.24. Mostly bug fixes.
(Portage version: 2.2_rc11/cvs/Linux 2.6.24-gentoo-r8 i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/vte-0.17.4.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 94685f2270f1..0d0405fa704e 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.209 2008/09/25 14:14:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.210 2008/10/10 14:08:21 eva Exp $
+
+*vte-0.17.4 (10 Oct 2008)
+
+ 10 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org> +vte-0.17.4.ebuild:
+ New version for GNOME 2.24. Mostly bug fixes.
25 Sep 2008; Jeroen Roovers <jer@gentoo.org> vte-0.16.14.ebuild:
Stable for HPPA (bug #236971).
diff --git a/x11-libs/vte/vte-0.17.4.ebuild b/x11-libs/vte/vte-0.17.4.ebuild
new file mode 100644
index 000000000000..d7615f0ec751
--- /dev/null
+++ b/x11-libs/vte/vte-0.17.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.17.4.ebuild,v 1.1 2008/10/10 14:08:21 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="Gnome terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+# pcre is broken in this release
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.4.4-r5
+ )
+ x11-libs/libX11
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_enable python)
+ $(use_with opengl glX)
+ --with-xft2 --with-pangox"
+}